p PatchFirst

CVE-2016-5354

CVE-2016-5354

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The USB subsystem in Wireshark 1.12.x before 1.12.12 and 2.x before 2.0.4 mishandles class types, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

CVSS 5.9 · Medium · EPSS 2.7% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • wireshark Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.0.4+gdd7746e-1

    Update to 2.0.4+gdd7746e-1

  • wireshark Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.0.4+gdd7746e-1

    Update to 2.0.4+gdd7746e-1

  • wireshark Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.0.4+gdd7746e-1

    Update to 2.0.4+gdd7746e-1

  • wireshark Ubuntu:14.04:LTS

    Versions
    • 1.10.2-1
    • 1.10.3-1
    • 1.10.5-1ubuntu1
    • 1.10.5-2
    • 1.10.6-1
    Affected ranges
    • ECOSYSTEM: < 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1

    Update to 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1

  • wireshark Ubuntu:16.04:LTS

    Versions
    • 1.12.7+g7fc8978-1
    • 1.12.8+g5b6e543-2
    • 2.0.1+g59ea380-3build1
    • 2.0.2+ga16e22e-1
    Affected ranges
    • ECOSYSTEM: < 2.2.6+g32dac6a-2ubuntu0.16.04

    Update to 2.2.6+g32dac6a-2ubuntu0.16.04

Original sources

Check your server →