p PatchFirst

CVE-2016-5769

CVE-2016-5769

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in mcrypt.c in the mcrypt extension in PHP before 5.5.37, 5.6.x before 5.6.23, and 7.x before 7.0.8 allow remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted length value, related to the (1) mcrypt_generic and (2) mdecrypt_generic functions.

CVSS 9.8 · Critical · EPSS 8.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    • 5.5.9+dfsg-1ubuntu4.7
    • 5.5.9+dfsg-1ubuntu4.9
    • 5.5.9+dfsg-1ubuntu4.11
    • 5.5.9+dfsg-1ubuntu4.12
    • 5.5.9+dfsg-1ubuntu4.13
    • 5.5.9+dfsg-1ubuntu4.14
    • 5.5.9+dfsg-1ubuntu4.16
    • 5.5.9+dfsg-1ubuntu4.17
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.19

    Update to 5.5.9+dfsg-1ubuntu4.19

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    • 7.0.4-7ubuntu2.1
    Affected ranges
    • ECOSYSTEM: < 7.0.8-0ubuntu0.16.04.1

    Update to 7.0.8-0ubuntu0.16.04.1

Original sources

Check your server →