CVE-2016-6233
CVE-2016-6233
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The (1) order and (2) group methods in Zend_Db_Select in the Zend Framework before 1.12.19 might allow remote attackers to conduct SQL injection attacks via vectors related to use of the character pattern [\w]* in a regular expression.
CVSS 9.8 · Critical · EPSS 2.0% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
zendframework/zendframework Packagist
- Affected ranges
- ECOSYSTEM: < 1.12.19
Update to 1.12.19
zendframework/zendframework1 Packagist
- Versions
- 1.12.0
- 1.12.1
- 1.12.10
- 1.12.11
- 1.12.12
- 1.12.13
- 1.12.14
- 1.12.15
- 1.12.16
- 1.12.17
- 1.12.18
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.5
- 1.12.6
- 1.12.7
- 1.12.8
- 1.12.9
- Affected ranges
- ECOSYSTEM: < 1.12.19
Update to 1.12.19
php-zend-db Ubuntu:16.04:LTS
- Versions
- 2.3.7-1
- 2.6.1-1
- 2.6.2-1
- 2.6.2-1build1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UR5HXNGIUSSIZKMSZYMPBEPZEZTYFTIT/
- https://security.gentoo.org/glsa/201804-10
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2JUKFTI6ABK7ZN7IEAGPCLAHCFANMID2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/N27AV6AL6B4KGEP3VIMIHQ5LFAKF5FTU/
- https://framework.zend.com/security/advisory/ZF2016-02
- http://www.securityfocus.com/bid/91802
- https://nvd.nist.gov/vuln/detail/CVE-2016-6233