p PatchFirst

CVE-2016-6316

CVE-2016-6316

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in Action View in Ruby on Rails 3.x before 3.2.22.3, 4.x before 4.2.7.1, and 5.x before 5.0.0.1 might allow remote attackers to inject arbitrary web script or HTML via text declared as "HTML safe" and used as attribute values in tag handlers.

CVSS 6.1 · Medium · EPSS 3.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • rails Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:4.2.7.1-1

    Update to 2:4.2.7.1-1

  • rails Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:4.2.7.1-1

    Update to 2:4.2.7.1-1

  • rails Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:4.2.7.1-1

    Update to 2:4.2.7.1-1

Original sources

Check your server →