CVE-2016-6509
CVE-2016-6509
This page contains facts from public vulnerability sources. Check the original advisory before updating.
epan/dissectors/packet-ldss.c in the LDSS dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 mishandles conversations, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
CVSS 5.9 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wireshark Debian:12
- Affected ranges
- ECOSYSTEM: < 2.0.5+ga3be9c6-1
Update to 2.0.5+ga3be9c6-1
wireshark Debian:13
- Affected ranges
- ECOSYSTEM: < 2.0.5+ga3be9c6-1
Update to 2.0.5+ga3be9c6-1
wireshark Debian:14
- Affected ranges
- ECOSYSTEM: < 2.0.5+ga3be9c6-1
Update to 2.0.5+ga3be9c6-1
wireshark Ubuntu:14.04:LTS
- Versions
- 1.10.2-1
- 1.10.3-1
- 1.10.5-1ubuntu1
- 1.10.5-2
- 1.10.6-1
- Affected ranges
- ECOSYSTEM: < 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
Update to 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
wireshark Ubuntu:16.04:LTS
- Versions
- 1.12.7+g7fc8978-1
- 1.12.8+g5b6e543-2
- 2.0.1+g59ea380-3build1
- 2.0.2+ga16e22e-1
- Affected ranges
- ECOSYSTEM: < 2.2.6+g32dac6a-2ubuntu0.16.04
Update to 2.2.6+g32dac6a-2ubuntu0.16.04
Original sources
- http://openwall.com/lists/oss-security/2016/07/28/3
- https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=12662
- http://www.debian.org/security/2016/dsa-3648
- http://www.wireshark.org/security/wnpa-sec-2016-45.html
- http://www.securitytracker.com/id/1036480
- https://code.wireshark.org/review/gitweb?p=wireshark.git%3Ba=commit%3Bh=5a469ddc893f7c1912d0e15cc73bd3011e6cc2fb
- https://nvd.nist.gov/vuln/detail/CVE-2016-6509