CVE-2016-7101
CVE-2016-7101
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The SGI coder in ImageMagick before 7.0.2-10 allows remote attackers to cause a denial of service (out-of-bounds read) via a large row value in an sgi file.
CVSS 6.5 · Medium · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.9.6.2+dfsg-2
Update to 8:6.9.6.2+dfsg-2
imagemagick Ubuntu:14.04:LTS
- Versions
- 8:6.7.7.10-5ubuntu3
- 8:6.7.7.10-5ubuntu4
- 8:6.7.7.10-6ubuntu1
- 8:6.7.7.10-6ubuntu2
- 8:6.7.7.10-6ubuntu3
- 8:6.7.7.10-6ubuntu3.1
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.2
Update to 8:6.7.7.10-6ubuntu3.2
imagemagick Ubuntu:16.04:LTS
- Versions
- 8:6.8.9.9-5ubuntu2
- 8:6.8.9.9-6
- 8:6.8.9.9-6build1
- 8:6.8.9.9-7
- 8:6.8.9.9-7ubuntu1
- 8:6.8.9.9-7ubuntu2
- 8:6.8.9.9-7ubuntu3
- 8:6.8.9.9-7ubuntu4
- 8:6.8.9.9-7ubuntu5
- 8:6.8.9.9-7ubuntu5.1
- Affected ranges
- ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.2
Update to 8:6.8.9.9-7ubuntu5.2
Original sources
- http://www.securityfocus.com/bid/93181
- https://github.com/ImageMagick/ImageMagick/commit/7afcf9f71043df15508e46f079387bd4689a738d
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836776
- http://www.openwall.com/lists/oss-security/2016/09/26/8
- https://github.com/ImageMagick/ImageMagick/commit/8f8959033e4e59418d6506b345829af1f7a71127
- https://nvd.nist.gov/vuln/detail/CVE-2016-7101