p PatchFirst

CVE-2016-7127

CVE-2016-7127

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The imagegammacorrect function in ext/gd/gd.c in PHP before 5.6.25 and 7.x before 7.0.10 does not properly validate gamma values, which allows remote attackers to cause a denial of service (out-of-bounds write) or possibly have unspecified other impact by providing different signs for the second and third arguments.

CVSS 9.8 · Critical · EPSS 6.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • php5 Ubuntu:14.04:LTS

    Versions
    • 5.5.3+dfsg-1ubuntu2
    • 5.5.3+dfsg-1ubuntu3
    • 5.5.6+dfsg-1ubuntu1
    • 5.5.6+dfsg-1ubuntu2
    • 5.5.8+dfsg-2ubuntu1
    • 5.5.9+dfsg-1ubuntu1
    • 5.5.9+dfsg-1ubuntu2
    • 5.5.9+dfsg-1ubuntu3
    • 5.5.9+dfsg-1ubuntu4
    • 5.5.9+dfsg-1ubuntu4.1
    • 5.5.9+dfsg-1ubuntu4.2
    • 5.5.9+dfsg-1ubuntu4.3
    • 5.5.9+dfsg-1ubuntu4.4
    • 5.5.9+dfsg-1ubuntu4.5
    • 5.5.9+dfsg-1ubuntu4.6
    • 5.5.9+dfsg-1ubuntu4.7
    • 5.5.9+dfsg-1ubuntu4.9
    • 5.5.9+dfsg-1ubuntu4.11
    • 5.5.9+dfsg-1ubuntu4.12
    • 5.5.9+dfsg-1ubuntu4.13
    • 5.5.9+dfsg-1ubuntu4.14
    • 5.5.9+dfsg-1ubuntu4.16
    • 5.5.9+dfsg-1ubuntu4.17
    • 5.5.9+dfsg-1ubuntu4.19
    Affected ranges
    • ECOSYSTEM: < 5.5.9+dfsg-1ubuntu4.20

    Update to 5.5.9+dfsg-1ubuntu4.20

  • php7.0 Ubuntu:16.04:LTS

    Versions
    • 7.0.1-5
    • 7.0.1-6
    • 7.0.2-1
    • 7.0.2-3
    • 7.0.2-4
    • 7.0.2-5
    • 7.0.3-2
    • 7.0.3-3
    • 7.0.3-9ubuntu1
    • 7.0.4-5ubuntu1
    • 7.0.4-5ubuntu2
    • 7.0.4-7ubuntu1
    • 7.0.4-7ubuntu2
    • 7.0.4-7ubuntu2.1
    • 7.0.8-0ubuntu0.16.04.1
    • 7.0.8-0ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: < 7.0.8-0ubuntu0.16.04.3

    Update to 7.0.8-0ubuntu0.16.04.3

Original sources

Check your server →