p PatchFirst

CVE-2016-7405

CVE-2016-7405

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

CVSS 9.8 · Critical · EPSS 3.0% · Fix available

Published
Updated

Stack: system · php

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libphp-adodb Debian:12

    Affected ranges
    • ECOSYSTEM: < 5.20.6-1

    Update to 5.20.6-1

  • libphp-adodb Debian:13

    Affected ranges
    • ECOSYSTEM: < 5.20.6-1

    Update to 5.20.6-1

  • libphp-adodb Debian:14

    Affected ranges
    • ECOSYSTEM: < 5.20.6-1

    Update to 5.20.6-1

  • adodb/adodb-php Packagist

    Versions
    • v5.19
    • v5.20.0
    • v5.20.1
    • v5.20.2
    • v5.20.3
    • v5.20.4
    • v5.20.5
    • v5.20.6
    Affected ranges
    • ECOSYSTEM: ≥ 5.0, < 5.20.7

    Update to 5.20.7

  • libphp-adodb Ubuntu:Pro:16.04:LTS

    Versions
    • 5.18a-1
    • 5.20.1-1
    • 5.20.2-1
    • 5.20.2-2
    • 5.20.3-1
    • 5.20.3-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 5.20.3-1ubuntu1+esm1

    Update to 5.20.3-1ubuntu1+esm1

Original sources

Check your server →