CVE-2016-7415
CVE-2016-7415
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Stack-based buffer overflow in the Locale class in common/locid.cpp in International Components for Unicode (ICU) through 57.1 for C/C++ allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a long locale string.
CVSS 9.8 · Critical · EPSS 5.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
icu Debian:12
- Affected ranges
- ECOSYSTEM: < 57.1-5
Update to 57.1-5
icu Debian:13
- Affected ranges
- ECOSYSTEM: < 57.1-5
Update to 57.1-5
icu Debian:14
- Affected ranges
- ECOSYSTEM: < 57.1-5
Update to 57.1-5
icu Ubuntu:14.04:LTS
- Versions
- 4.8.1.1-12ubuntu2
- 4.8.1.1-13+nmu1
- 4.8.1.1-13+nmu1ubuntu1
- 52.1-3
- 52.1-3ubuntu0.2
- 52.1-3ubuntu0.3
- 52.1-3ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 52.1-3ubuntu0.5
Update to 52.1-3ubuntu0.5
icu Ubuntu:16.04:LTS
- Versions
- 55.1-4ubuntu1
- 55.1-6ubuntu1
- 55.1-7
- Affected ranges
- ECOSYSTEM: < 55.1-7ubuntu0.1
Update to 55.1-7ubuntu0.1
Original sources
- https://bugs.php.net/bug.php?id=73007
- http://www.openwall.com/lists/oss-security/2016/09/15/10
- https://security.gentoo.org/glsa/201701-58
- https://www.tenable.com/security/tns-2016-19
- http://www.securityfocus.com/bid/93022
- https://www.oracle.com/technetwork/security-advisory/cpuapr2019-5072813.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-7415