p PatchFirst

CVE-2016-7946

CVE-2016-7946

This page contains facts from public vulnerability sources. Check the original advisory before updating.

X.org libXi before 1.7.7 allows remote X servers to cause a denial of service (infinite loop) via vectors involving length fields.

CVSS 7.5 · High · EPSS 3.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxi Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:1.7.8-1

    Update to 2:1.7.8-1

  • libxi Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:1.7.8-1

    Update to 2:1.7.8-1

  • libxi Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:1.7.8-1

    Update to 2:1.7.8-1

  • libxi Ubuntu:Pro:16.04:LTS

    Versions
    • 2:1.7.4-1
    • 2:1.7.5-1
    • 2:1.7.6-1
    Affected ranges
    • ECOSYSTEM: < 2:1.7.6-1ubuntu0.1~esm1

    Update to 2:1.7.6-1ubuntu0.1~esm1

Original sources

Check your server →