p PatchFirst

CVE-2016-7951

CVE-2016-7951

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks.

CVSS 9.8 · Critical · EPSS 2.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libxtst Debian:12

    Affected ranges
    • ECOSYSTEM: < 2:1.2.3-1

    Update to 2:1.2.3-1

  • libxtst Debian:13

    Affected ranges
    • ECOSYSTEM: < 2:1.2.3-1

    Update to 2:1.2.3-1

  • libxtst Debian:14

    Affected ranges
    • ECOSYSTEM: < 2:1.2.3-1

    Update to 2:1.2.3-1

  • libxtst Ubuntu:Pro:16.04:LTS

    Versions
    • 2:1.2.2-1
    Affected ranges
    • ECOSYSTEM: < 2:1.2.2-1ubuntu0.1~esm1

    Update to 2:1.2.2-1ubuntu0.1~esm1

Original sources

Check your server →