CVE-2016-7998
CVE-2016-7998
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The SPIP template composer/compiler in SPIP 3.1.2 and earlier allows remote authenticated users to execute arbitrary PHP code by uploading an HTML file with a crafted (1) INCLUDE or (2) INCLURE tag and then accessing it with a valider_xml action.
CVSS 8.8 · High · EPSS 13.3% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
spip Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.3-1
Update to 3.1.3-1
spip Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.3-1
Update to 3.1.3-1
spip Ubuntu:Pro:16.04:LTS
- Versions
- 3.0.20-1
- 3.0.21-1
- 3.0.21-1ubuntu1
- 3.0.21-1ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- http://www.securityfocus.com/bid/93451
- https://core.spip.net/projects/spip/repository/revisions/23189
- https://core.spip.net/projects/spip/repository/revisions/23192
- https://core.spip.net/projects/spip/repository/revisions/23186
- http://www.openwall.com/lists/oss-security/2016/10/07/5
- http://www.openwall.com/lists/oss-security/2016/10/08/6
- https://sysdream.com/news/lab/2016-10-19-spip-3-1-2-template-compiler-composer-php-code-execution-cve-2016-7998/
- http://www.openwall.com/lists/oss-security/2016/10/05/17
- https://nvd.nist.gov/vuln/detail/CVE-2016-7998