p PatchFirst

CVE-2016-8614

CVE-2016-8614

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

CVSS 6.3 · Medium · EPSS 2.5% · Fix available

Published
Updated

Stack: system · python

Affected products and versions

  • ansible

    Versions
    • 2.2.0: Affected

    No fix published

  • ansible Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.0.0-1

    Update to 2.2.0.0-1

  • ansible Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.0.0-1

    Update to 2.2.0.0-1

  • ansible Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.0.0-1

    Update to 2.2.0.0-1

  • ansible PyPI

    Versions
    • 1.0
    • 1.1
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.4
    • 1.4.1
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.5
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.6
    • 1.6.1
    • 1.6.10
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    • 1.6.9
    • 1.7
    • 1.7.1
    • 1.7.2
    • 1.8
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.9.0
    • 1.9.0.1
    • 1.9.1
    • 1.9.2
    • 1.9.3
    • 1.9.4
    • 1.9.5
    • 1.9.6
    • 2.0.0
    • 2.0.0.0
    • 2.0.0.1
    • 2.0.0.2
    • 2.0.1.0
    • 2.0.2.0
    • 2.1.0.0
    • 2.1.1.0
    • 2.1.2.0
    • 2.1.3.0
    • 2.1.4.0
    • 2.1.5.0
    • 2.1.6.0
    Affected ranges
    • ECOSYSTEM: < 2.2.0.0

    Update to 2.2.0.0

  • ansible Ubuntu:Pro:14.04:LTS

    Versions
    • 1.1+dfsg-1
    • 1.3.4+dfsg-1
    • 1.4.0+dfsg-1
    • 1.4.1+dfsg-1
    • 1.4.3+dfsg-1
    • 1.4.4+dfsg-1
    • 1.5.4+dfsg-1
    • 1.5.4+dfsg-1ubuntu0.1~esm1
    • 1.5.4+dfsg-1ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: < 1.5.4+dfsg-1ubuntu0.1~esm3

    Update to 1.5.4+dfsg-1ubuntu0.1~esm3

  • ansible Ubuntu:Pro:16.04:LTS

    Versions
    • 1.9.2+dfsg-2
    • 1.9.4-1
    • 2.0.0.2-2
    • 2.0.0.2-2ubuntu1
    • 2.0.0.2-2ubuntu1.1
    • 2.0.0.2-2ubuntu1.2
    • 2.0.0.2-2ubuntu1.3
    • 2.0.0.2-2ubuntu1.3+esm1
    • 2.0.0.2-2ubuntu1.3+esm2
    • 2.0.0.2-2ubuntu1.3+esm3
    • 2.0.0.2-2ubuntu1.3+esm4
    Affected ranges
    • ECOSYSTEM: < 2.0.0.2-2ubuntu1.3+esm5

    Update to 2.0.0.2-2ubuntu1.3+esm5

Original sources

Check your server →