CVE-2016-8642
CVE-2016-8642
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
CVSS 5.3 · Medium · EPSS 1.2% · Fix available
- Published
- Updated
Affected products and versions
moodle 2.x and 3.x
- Versions
- Moodle 2.x and 3.x: Affected
No fix published
moodle/moodle Packagist
- Versions
- v3.1.0
- v3.1.1
- v3.1.2
- Affected ranges
- ECOSYSTEM: ≥ 3.1.0, < 3.1.3
Update to 3.1.3
moodle/moodle Packagist
- Versions
- v3.0.0
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- Affected ranges
- ECOSYSTEM: ≥ 3.0.0, < 3.0.7
Update to 3.0.7
moodle/moodle Packagist
- Versions
- v2.9.0
- v2.9.1
- v2.9.2
- v2.9.3
- v2.9.4
- v2.9.5
- v2.9.6
- v2.9.7
- v2.9.8
- Affected ranges
- ECOSYSTEM: ≥ 2.9.0, < 2.9.9
Update to 2.9.9
moodle/moodle Packagist
- Versions
- v2.8.0
- v2.8.1
- v2.8.10
- v2.8.11
- v2.8.12
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v2.8.9
- Affected ranges
- ECOSYSTEM: ≥ 2.8.0, ≤ 2.8.12
No fix published
moodle/moodle Packagist
- Versions
- v2.7.0
- v2.7.1
- v2.7.10
- v2.7.11
- v2.7.12
- v2.7.13
- v2.7.14
- v2.7.15
- v2.7.16
- v2.7.2
- v2.7.3
- v2.7.4
- v2.7.5
- v2.7.6
- v2.7.7
- v2.7.8
- v2.7.9
- Affected ranges
- ECOSYSTEM: ≥ 2.7.0, < 2.7.17
Update to 2.7.17
moodle Ubuntu:Pro:16.04:LTS
- Versions
- 2.7.9+dfsg-1
- 2.7.10+dfsg-1
- 2.7.11+dfsg-1
- 2.7.11+dfsg-2
- 2.7.12+dfsg-1
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
moodle Ubuntu:Pro:18.04:LTS
- Versions
- 3.0.3+dfsg-0ubuntu1
- 3.0.3+dfsg-0ubuntu1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published