p PatchFirst

CVE-2016-8735

CVE-2016-8735

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This page shows selected source facts. See the linked advisories for the complete description and affected versions.

Remote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if JmxRemoteLifecycleListener is used and an attacker can reach JMX ports. The issue exists because this listener wasn't updated for consistency with the CVE-2016-3427 Oracle patch that affected credential types.

CVSS 9.8 · Critical · EPSS 90.3% · In KEV · Fix available

Published
Updated

Stack: system

Affected products and versions

  • apache tomcat

    Versions
    • before 6.0.48: Affected
    • 7.x before 7.0.73: Affected
    • 8.x before 8.0.39: Affected
    • 8.5.x before 8.5.7: Affected
    • 9.x before 9.0.0.M12: Affected

    No fix published

  • tomcat7 Ubuntu:14.04:LTS

    Versions
    • 7.0.42-1
    • 7.0.47-1
    • 7.0.50-1
    • 7.0.52-1
    • 7.0.52-1ubuntu0.1
    • 7.0.52-1ubuntu0.3
    • 7.0.52-1ubuntu0.6
    • 7.0.52-1ubuntu0.7
    Affected ranges
    • ECOSYSTEM: < 7.0.52-1ubuntu0.8

    Update to 7.0.52-1ubuntu0.8

  • tomcat6 Ubuntu:Pro:14.04:LTS

    Versions
    • 6.0.37-1
    • 6.0.39-1
    • 6.0.39-1ubuntu0.1
    • 6.0.39-1ubuntu0.1+esm1
    Affected ranges
    • ECOSYSTEM: < 6.0.39-1ubuntu0.1+esm2

    Update to 6.0.39-1ubuntu0.1+esm2

  • tomcat6 Ubuntu:16.04:LTS

    Versions
    • 6.0.41-4
    • 6.0.45+dfsg-1
    Affected ranges
    • ECOSYSTEM: < 6.0.45+dfsg-1ubuntu0.1

    Update to 6.0.45+dfsg-1ubuntu0.1

  • tomcat7 Ubuntu:16.04:LTS

    Versions
    • 7.0.64-1
    • 7.0.68-1
    • 7.0.68-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 7.0.68-1ubuntu0.3

    Update to 7.0.68-1ubuntu0.3

  • tomcat8 Ubuntu:16.04:LTS

    Versions
    • 8.0.26-1
    • 8.0.28-1
    • 8.0.30-1
    • 8.0.32-1
    • 8.0.32-1ubuntu1
    • 8.0.32-1ubuntu1.1
    • 8.0.32-1ubuntu1.2
    Affected ranges
    • ECOSYSTEM: < 8.0.32-1ubuntu1.3

    Update to 8.0.32-1ubuntu1.3

Original sources

Check your server →