CVE-2016-9013
CVE-2016-9013
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Django 1.8.x before 1.8.16, 1.9.x before 1.9.11, and 1.10.x before 1.10.3 use a hardcoded password for a temporary database user created when running tests with an Oracle database, which makes it easier for remote attackers to obtain access to the database server by leveraging failure to manually specify a password in the database settings TEST dictionary.
CVSS 9.8 · Critical · EPSS 5.2% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
python-django Debian:12
- Affected ranges
- ECOSYSTEM: < 1:1.10.3-1
Update to 1:1.10.3-1
python-django Debian:13
- Affected ranges
- ECOSYSTEM: < 1:1.10.3-1
Update to 1:1.10.3-1
python-django Debian:14
- Affected ranges
- ECOSYSTEM: < 1:1.10.3-1
Update to 1:1.10.3-1
django PyPI
- Versions
- 1.10
- 1.10.1
- 1.10.2
- 1.10a1
- 1.10b1
- 1.10rc1
- Affected ranges
- ECOSYSTEM: ≥ 1.10a1, < 1.10.3
Update to 1.10.3
django PyPI
- Versions
- 1.9
- 1.9.1
- 1.9.10
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 1.9.7
- 1.9.8
- 1.9.9
- 1.9a1
- 1.9b1
- 1.9rc1
- 1.9rc2
- Affected ranges
- ECOSYSTEM: ≥ 1.9a1, < 1.9.11
Update to 1.9.11
django PyPI
- Versions
- 1.8
- 1.8.1
- 1.8.10
- 1.8.11
- 1.8.12
- 1.8.13
- 1.8.14
- 1.8.15
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 1.8.6
- 1.8.7
- 1.8.8
- 1.8.9
- 1.8a1
- 1.8b1
- 1.8b2
- 1.8c1
- Affected ranges
- ECOSYSTEM: ≥ 1.8a1, < 1.8.16
Update to 1.8.16
django PyPI
- Versions
- 1.10
- 1.10.1
- 1.10.2
- 1.8
- 1.8.1
- 1.8.10
- 1.8.11
- 1.8.12
- 1.8.13
- 1.8.14
- 1.8.15
- 1.8.2
- 1.8.3
- 1.8.4
- 1.8.5
- 1.8.6
- 1.8.7
- 1.8.8
- 1.8.9
- 1.9
- 1.9.1
- 1.9.10
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 1.9.7
- 1.9.8
- 1.9.9
- Affected ranges
- ECOSYSTEM: ≥ 1.8, < 1.8.16 ∪ ≥ 1.9, < 1.9.11 ∪ ≥ 1.10, < 1.10.3
Update to 1.8.16; Update to 1.9.11; Update to 1.10.3
python-django Ubuntu:14.04:LTS
- Versions
- 1.5.4-1ubuntu1
- 1.6-1
- 1.6.1-1
- 1.6.1-2
- 1.6.1-2ubuntu0.1
- 1.6.1-2ubuntu0.2
- 1.6.1-2ubuntu0.3
- 1.6.1-2ubuntu0.4
- 1.6.1-2ubuntu0.5
- 1.6.1-2ubuntu0.6
- 1.6.1-2ubuntu0.8
- 1.6.1-2ubuntu0.9
- 1.6.1-2ubuntu0.10
- 1.6.1-2ubuntu0.11
- 1.6.1-2ubuntu0.12
- 1.6.1-2ubuntu0.13
- 1.6.1-2ubuntu0.14
- 1.6.1-2ubuntu0.15
- Affected ranges
- ECOSYSTEM: < 1.6.1-2ubuntu0.16
Update to 1.6.1-2ubuntu0.16
python-django Ubuntu:16.04:LTS
- Versions
- 1.7.9-1ubuntu5
- 1.8.5-2ubuntu1
- 1.8.7-1ubuntu1
- 1.8.7-1ubuntu2
- 1.8.7-1ubuntu3
- 1.8.7-1ubuntu4
- 1.8.7-1ubuntu5
- 1.8.7-1ubuntu5.1
- 1.8.7-1ubuntu5.2
- Affected ranges
- ECOSYSTEM: < 1.8.7-1ubuntu5.4
Update to 1.8.7-1ubuntu5.4
Original sources
- https://www.djangoproject.com/weblog/2016/nov/01/security-releases/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QXDKJYHN74BWY3P7AR2UZDVJREQMRE6S/
- http://www.debian.org/security/2017/dsa-3835
- http://www.ubuntu.com/usn/USN-3115-1
- http://www.securityfocus.com/bid/94069
- http://www.securitytracker.com/id/1037159
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OG5ROMUPS6C7BXELD3TAUUH7OBYV56WQ/
- https://nvd.nist.gov/vuln/detail/CVE-2016-9013