p PatchFirst

CVE-2016-9015

CVE-2016-9015

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.

CVSS 6.3 · Medium · EPSS 0.8% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • urllib3 PyPI

    Versions
    • 1.17
    • 1.18
    Affected ranges
    • ECOSYSTEM: ≥ 1.17, < 1.18.1

    Update to 1.18.1

Original sources

Check your server →