CVE-2016-9063
CVE-2016-9063
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An integer overflow during the parsing of XML using the Expat library. This vulnerability affects Firefox < 50.
CVSS 9.8 · Critical · EPSS 5.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
firefox
- Versions
- ≥ unspecified, < 50: Affected (custom)
Update to 50
expat Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.0-2
Update to 2.2.0-2
expat Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.0-2
Update to 2.2.0-2
expat Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.0-2
Update to 2.2.0-2
libxmltok Debian:12
- Versions
- 1.2-4
- 1.2-4.1
- 1.2-4.1~exp1
- 1.2-4.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- 45.0+build2-0ubuntu0.14.04.1
- 45.0.1+build1-0ubuntu0.14.04.2
- 45.0.2+build1-0ubuntu0.14.04.1
- 46.0+build5-0ubuntu0.14.04.2
- 46.0.1+build1-0ubuntu0.14.04.3
- 47.0+build3-0ubuntu0.14.04.1
- 48.0+build2-0ubuntu0.14.04.1
- 49.0+build4-0ubuntu0.14.04.1
- 49.0.2+build2-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 50.0+build2-0ubuntu0.14.04.2
Update to 50.0+build2-0ubuntu0.14.04.2
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- 46.0+build5-0ubuntu0.16.04.2
- 46.0.1+build1-0ubuntu0.16.04.2
- 47.0+build3-0ubuntu0.16.04.1
- 48.0+build2-0ubuntu0.16.04.1
- 49.0+build4-0ubuntu0.16.04.1
- 49.0.2+build2-0ubuntu0.16.04.2
- Affected ranges
- ECOSYSTEM: < 50.0+build2-0ubuntu0.16.04.2
Update to 50.0+build2-0ubuntu0.16.04.2
Original sources
- https://www.debian.org/security/2017/dsa-3898
- http://www.securityfocus.com/bid/94337
- https://bugzilla.mozilla.org/show_bug.cgi?id=1274777
- http://www.securitytracker.com/id/1037298
- http://www.securitytracker.com/id/1039427
- https://www.mozilla.org/security/advisories/mfsa2016-89/
- https://nvd.nist.gov/vuln/detail/CVE-2016-9063