CVE-2016-9189
CVE-2016-9189
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Pillow before 3.3.2 allows context-dependent attackers to obtain sensitive information by using the "crafted image file" approach, related to an "Integer Overflow" issue affecting the Image.core.map_buffer in map.c component.
CVSS 6.9 · Medium · EPSS 1.9% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
pillow Debian:12
- Affected ranges
- ECOSYSTEM: < 3.4.2-1
Update to 3.4.2-1
pillow Debian:13
- Affected ranges
- ECOSYSTEM: < 3.4.2-1
Update to 3.4.2-1
pillow Debian:14
- Affected ranges
- ECOSYSTEM: < 3.4.2-1
Update to 3.4.2-1
pillow PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.3
- 1.4
- 1.5
- 1.6
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.7.8
- 2.0.0
- 2.1.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.3.2
- 2.4.0
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.6.0
- 2.6.1
- 2.6.2
- 2.7.0
- 2.8.0
- 2.8.1
- 2.8.2
- 2.9.0
- 3.0.0
- 3.1.0
- 3.1.0.rc1
- 3.1.0rc1
- 3.1.1
- 3.1.2
- 3.2.0
- 3.3.0
- 3.3.1
- Affected ranges
- ECOSYSTEM: < 3.3.2
Update to 3.3.2
pillow Ubuntu:14.04:LTS
- Versions
- 2.2.1-1ubuntu2
- 2.2.1-2ubuntu1
- 2.2.1-3ubuntu2
- 2.2.1-3ubuntu3
- 2.2.1-3ubuntu4
- 2.2.1-3ubuntu6
- 2.3.0-1ubuntu1
- 2.3.0-1ubuntu2
- 2.3.0-1ubuntu3
- 2.3.0-1ubuntu3.2
- 2.3.0-1ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 2.3.0-1ubuntu3.4
Update to 2.3.0-1ubuntu3.4
pillow Ubuntu:16.04:LTS
- Versions
- 2.9.0-1
- 3.0.0-1
- 3.0.0-1build1
- 3.1.0-1
- 3.1.1-1
- 3.1.2-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 3.1.2-0ubuntu1.1
Update to 3.1.2-0ubuntu1.1
Original sources
- https://github.com/python-pillow/Pillow/pull/2146/commits/c50ebe6459a131a1ea8ca531f10da616d3ceaa0f
- https://security.gentoo.org/glsa/201612-52
- http://www.securityfocus.com/bid/94234
- https://github.com/python-pillow/Pillow/issues/2105
- http://www.debian.org/security/2016/dsa-3710
- http://pillow.readthedocs.io/en/3.4.x/releasenotes/3.3.2.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-9189