CVE-2016-9587
CVE-2016-9587
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems. An attacker with control over a client system being managed by Ansible and the ability to send facts back to the Ansible server could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
CVSS 6.6 · Medium · EPSS 17.1% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
ansible
- Versions
- ansible 2.1.4: Affected
- ansible 2.2.1: Affected
No fix published
ansible Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.0.0-3
Update to 2.2.0.0-3
ansible Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.0.0-3
Update to 2.2.0.0-3
ansible Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.0.0-3
Update to 2.2.0.0-3
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- Affected ranges
- ECOSYSTEM: < 2.1.4.0
Update to 2.1.4.0
ansible PyPI
- Versions
- 2.2.0.0
- Affected ranges
- ECOSYSTEM: ≥ 2.2.0.0, < 2.2.1.0
Update to 2.2.1.0
ansible PyPI
- Versions
- 1.0
- 1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.4.5
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.5.5
- 1.6
- 1.6.1
- 1.6.10
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- 1.6.6
- 1.6.7
- 1.6.8
- 1.6.9
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 1.9.0.1
- 1.9.1
- 1.9.2
- 1.9.3
- 1.9.4
- 1.9.5
- 1.9.6
- 2.0.0
- 2.0.0.0
- 2.0.0.1
- 2.0.0.2
- 2.0.1.0
- 2.0.2.0
- 2.1.0.0
- 2.1.1.0
- 2.1.2.0
- 2.1.3.0
- 2.2.0.0
- Affected ranges
- ECOSYSTEM: < 2.1.4.0 ∪ ≥ 2.2.0.0, < 2.2.1.0
Update to 2.1.4.0; Update to 2.2.1.0
ansible Ubuntu:16.04:LTS
- Versions
- 1.9.2+dfsg-2
- 1.9.4-1
- 2.0.0.2-2
- 2.0.0.2-2ubuntu1
- Affected ranges
- ECOSYSTEM: < 2.0.0.2-2ubuntu1.1
Update to 2.0.0.2-2ubuntu1.1
Original sources
- https://access.redhat.com/errata/RHSA-2017:0515
- https://www.exploit-db.com/exploits/41013/
- https://security.gentoo.org/glsa/201701-77
- https://access.redhat.com/errata/RHSA-2017:1685
- http://www.securityfocus.com/bid/95352
- https://access.redhat.com/errata/RHSA-2017:0448
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9587
- http://rhn.redhat.com/errata/RHSA-2017-0195.html
- http://rhn.redhat.com/errata/RHSA-2017-0260.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-9587