CVE-2016-9901
CVE-2016-9901
This page contains facts from public vulnerability sources. Check the original advisory before updating.
HTML tags received from the Pocket server will be processed without sanitization and any JavaScript code executed will be run in the "about:pocket-saved" (unprivileged) page, giving it access to Pocket's messaging API through HTML injection. This vulnerability affects Firefox ESR < 45.6 and Firefox < 50.1.
CVSS 9.8 · Critical · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
firefox esr
- Versions
- ≥ unspecified, < 45.6: Affected (custom)
Update to 45.6
firefox
- Versions
- ≥ unspecified, < 50.1: Affected (custom)
Update to 50.1
firefox-esr Debian:12
- Affected ranges
- ECOSYSTEM: < 45.6.0esr-1
Update to 45.6.0esr-1
firefox-esr Debian:13
- Affected ranges
- ECOSYSTEM: < 45.6.0esr-1
Update to 45.6.0esr-1
firefox-esr Debian:14
- Affected ranges
- ECOSYSTEM: < 45.6.0esr-1
Update to 45.6.0esr-1
firefox Ubuntu:14.04:LTS
- Versions
- 24.0+build1-0ubuntu1
- 25.0+build3-0ubuntu0.13.10.1
- 28.0~b2+build1-0ubuntu2
- 28.0+build1-0ubuntu1
- 28.0+build2-0ubuntu1
- 28.0+build2-0ubuntu2
- 29.0+build1-0ubuntu0.14.04.2
- 30.0+build1-0ubuntu0.14.04.3
- 31.0+build1-0ubuntu0.14.04.1
- 32.0+build1-0ubuntu0.14.04.1
- 32.0.3+build1-0ubuntu0.14.04.1
- 33.0+build2-0ubuntu0.14.04.1
- 34.0+build2-0ubuntu0.14.04.1
- 35.0+build3-0ubuntu0.14.04.2
- 35.0.1+build1-0ubuntu0.14.04.1
- 36.0+build2-0ubuntu0.14.04.4
- 36.0.1+build2-0ubuntu0.14.04.1
- 36.0.4+build1-0ubuntu0.14.04.1
- 37.0+build2-0ubuntu0.14.04.1
- 37.0.1+build1-0ubuntu0.14.04.1
- 37.0.2+build1-0ubuntu0.14.04.1
- 38.0+build3-0ubuntu0.14.04.1
- 39.0+build5-0ubuntu0.14.04.1
- 39.0.3+build2-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.1
- 40.0+build4-0ubuntu0.14.04.4
- 40.0.3+build1-0ubuntu0.14.04.1
- 41.0+build3-0ubuntu0.14.04.1
- 41.0.1+build2-0ubuntu0.14.04.1
- 41.0.2+build2-0ubuntu0.14.04.1
- 42.0+build2-0ubuntu0.14.04.1
- 43.0+build1-0ubuntu0.14.04.1
- 43.0.4+build3-0ubuntu0.14.04.1
- 44.0+build3-0ubuntu0.14.04.1
- 44.0.1+build2-0ubuntu0.14.04.1
- 44.0.2+build1-0ubuntu0.14.04.1
- 45.0+build2-0ubuntu0.14.04.1
- 45.0.1+build1-0ubuntu0.14.04.2
- 45.0.2+build1-0ubuntu0.14.04.1
- 46.0+build5-0ubuntu0.14.04.2
- 46.0.1+build1-0ubuntu0.14.04.3
- 47.0+build3-0ubuntu0.14.04.1
- 48.0+build2-0ubuntu0.14.04.1
- 49.0+build4-0ubuntu0.14.04.1
- 49.0.2+build2-0ubuntu0.14.04.1
- 50.0+build2-0ubuntu0.14.04.2
- 50.0.2+build1-0ubuntu0.14.04.1
- Affected ranges
- ECOSYSTEM: < 50.1.0+build2-0ubuntu0.14.04.1
Update to 50.1.0+build2-0ubuntu0.14.04.1
firefox Ubuntu:16.04:LTS
- Versions
- 41.0.2+build2-0ubuntu1
- 42.0+build2-0ubuntu1
- 44.0+build3-0ubuntu2
- 44.0.1+build1-0ubuntu1
- 44.0.2+build1-0ubuntu1
- 45.0+build2-0ubuntu1
- 45.0.1+build1-0ubuntu1
- 45.0.2+build1-0ubuntu1
- 46.0+build5-0ubuntu0.16.04.2
- 46.0.1+build1-0ubuntu0.16.04.2
- 47.0+build3-0ubuntu0.16.04.1
- 48.0+build2-0ubuntu0.16.04.1
- 49.0+build4-0ubuntu0.16.04.1
- 49.0.2+build2-0ubuntu0.16.04.2
- 50.0+build2-0ubuntu0.16.04.2
- 50.0.2+build1-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 50.1.0+build2-0ubuntu0.16.04.1
Update to 50.1.0+build2-0ubuntu0.16.04.1
Original sources
- https://www.mozilla.org/security/advisories/mfsa2016-94/
- https://www.mozilla.org/security/advisories/mfsa2016-95/
- http://www.securityfocus.com/bid/94885
- http://www.securitytracker.com/id/1037461
- https://security.gentoo.org/glsa/201701-15
- http://rhn.redhat.com/errata/RHSA-2016-2973.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1320057
- http://rhn.redhat.com/errata/RHSA-2016-2946.html
- https://nvd.nist.gov/vuln/detail/CVE-2016-9901