CVE-2016-9936
CVE-2016-9936
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The unserialize implementation in ext/standard/var.c in PHP 7.x before 7.0.14 allows remote attackers to cause a denial of service (use-after-free) or possibly have unspecified other impact via crafted serialized data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-6834.
CVSS 9.8 · Critical · EPSS 4.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.15-0ubuntu0.16.04.2
Update to 7.0.15-0ubuntu0.16.04.2
Original sources
- http://www.openwall.com/lists/oss-security/2016/12/12/2
- http://www.php.net/ChangeLog-7.php
- https://github.com/php/php-src/commit/b2af4e8868726a040234de113436c6e4f6372d17
- https://access.redhat.com/errata/RHSA-2018:1296
- https://bugs.php.net/bug.php?id=72978
- http://lists.opensuse.org/opensuse-updates/2017-01/msg00034.html
- http://www.securityfocus.com/bid/94849
- https://nvd.nist.gov/vuln/detail/CVE-2016-9936