p PatchFirst

CVE-2016-9942

CVE-2016-9942

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Heap-based buffer overflow in ultra.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message with the Ultra type tile, such that the LZO payload decompressed length exceeds what is specified by the tile dimensions.

CVSS 9.8 · Critical · EPSS 3.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • libvncserver Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.9.11+dfsg-1

    Update to 0.9.11+dfsg-1

  • libvncserver Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.9.11+dfsg-1

    Update to 0.9.11+dfsg-1

  • libvncserver Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.9.11+dfsg-1

    Update to 0.9.11+dfsg-1

  • veyon Debian:12

    Affected ranges
    • ECOSYSTEM: < 4.1.4+repack1-1

    Update to 4.1.4+repack1-1

  • veyon Debian:13

    Affected ranges
    • ECOSYSTEM: < 4.1.4+repack1-1

    Update to 4.1.4+repack1-1

  • libvncserver Ubuntu:14.04:LTS

    Versions
    • 0.9.9+dfsg-1
    • 0.9.9+dfsg-1ubuntu1
    • 0.9.9+dfsg-1ubuntu1.1
    Affected ranges
    • ECOSYSTEM: < 0.9.9+dfsg-1ubuntu1.2

    Update to 0.9.9+dfsg-1ubuntu1.2

  • italc Ubuntu:16.04:LTS

    Versions
    • 1:2.0.2+dfsg1-3
    • 1:2.0.2+dfsg1-4
    Affected ranges
    • ECOSYSTEM: < 1:2.0.2+dfsg1-4ubuntu0.1

    Update to 1:2.0.2+dfsg1-4ubuntu0.1

  • libvncserver Ubuntu:16.04:LTS

    Versions
    • 0.9.10+dfsg-3
    • 0.9.10+dfsg-3build1
    Affected ranges
    • ECOSYSTEM: < 0.9.10+dfsg-3ubuntu0.16.04.1

    Update to 0.9.10+dfsg-3ubuntu0.16.04.1

Original sources

Check your server →