CVE-2017-1000427
CVE-2017-1000427
This page contains facts from public vulnerability sources. Check the original advisory before updating.
marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
CVSS 6.1 · Medium · EPSS 1.5% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
node-marked Debian:12
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
node-marked Debian:13
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
node-marked Debian:14
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
marked npm
- Affected ranges
- SEMVER: < 0.3.7
Update to 0.3.7
node-marked Ubuntu:16.04:LTS
- Versions
- 0.3.2+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://snyk.io/vuln/npm:marked:20170112
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BO2RMVVZVV6NFTU46B5RYRK7ZCXYARZS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M6BJG6RGDH7ZWVVAUFBFI5L32RSMQN2S/
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000427