CVE-2017-1000480
CVE-2017-1000480
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
CVSS 9.8 · Critical · EPSS 3.1% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
smarty3 Debian:12
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty3 Debian:13
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty3 Debian:14
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3
smarty/smarty Packagist
- Versions
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- Affected ranges
- ECOSYSTEM: ≥ 3, < 3.1.32
Update to 3.1.32
smarty3 Ubuntu:Pro:16.04:LTS
- Versions
- 3.1.21-1
- 3.1.21-1ubuntu1
- 3.1.21-1ubuntu1+esm1
- 3.1.21-1ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
smarty3 Ubuntu:18.04:LTS
- Versions
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- Affected ranges
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3
Update to 3.1.31+20161214.1.c7d42e4+selfpack1-3