CVE-2017-10116
CVE-2017-10116
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Vulnerability in the Java SE, Java SE Embedded, JRockit component of Oracle Java SE (subcomponent: Security). Supported versions that are affected are Java SE: 6u151, 7u141 and 8u131; Java SE Embedded: 8u131; JRockit: R28.3.14. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded, JRockit. Successful attacks require human interaction from a person other than the attacker and while the vulnerability is in Java SE, Java SE Embedded, JRockit, attacks may significantly impact additional products. Successful attacks of this vulnerability can result in takeover of Java SE, Java SE Embedded, JRockit. Note: This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.0 Base Score 8.3 (Confidentiality, Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H).
CVSS 8.3 · High · EPSS 3.4% · Fix available
- Published
- Updated
Stack: system · applications
Affected products and versions
java
- Versions
- Java SE: 6u151: Affected
- 7u141: Affected
- 8u131; Java SE Embedded: 8u131; JRockit: R28.3.14: Affected
No fix published
openjdk-7 Ubuntu:14.04:LTS
- Versions
- 7u25-2.3.12-4ubuntu3
- 7u25-2.3.12-4ubuntu5
- 7u45-2.4.3-3ubuntu1
- 7u45-2.4.3-3ubuntu2
- 7u45-2.4.3-4ubuntu1
- 7u45-2.4.3-4ubuntu2
- 7u51-2.4.4-1ubuntu1
- 7u51-2.4.5-1ubuntu1
- 7u51-2.4.6~pre1-1ubuntu2
- 7u51-2.4.6-1ubuntu3
- 7u51-2.4.6-1ubuntu4
- 7u55-2.4.7-1ubuntu1
- 7u65-2.5.1-4ubuntu1~0.14.04.1
- 7u65-2.5.1-4ubuntu1~0.14.04.2
- 7u65-2.5.2-3~14.04
- 7u71-2.5.3-0ubuntu0.14.04.1
- 7u75-2.5.4-1~trusty1
- 7u79-2.5.5-0ubuntu0.14.04.2
- 7u79-2.5.6-0ubuntu1.14.04.1
- 7u85-2.6.1-5ubuntu0.14.04.1
- 7u91-2.6.3-0ubuntu0.14.04.1
- 7u95-2.6.4-0ubuntu0.14.04.1
- 7u95-2.6.4-0ubuntu0.14.04.2
- 7u101-2.6.6-0ubuntu0.14.04.1
- 7u111-2.6.7-0ubuntu0.14.04.3
- 7u121-2.6.8-1ubuntu0.14.04.1
- 7u121-2.6.8-1ubuntu0.14.04.3
- 7u131-2.6.9-0ubuntu0.14.04.1
- 7u131-2.6.9-0ubuntu0.14.04.2
- Affected ranges
- ECOSYSTEM: < 7u151-2.6.11-0ubuntu1.14.04.1
Update to 7u151-2.6.11-0ubuntu1.14.04.1
openjdk-8 Ubuntu:16.04:LTS
- Versions
- 8u66-b01-5
- 8u72-b05-1ubuntu1
- 8u72-b05-5
- 8u72-b05-6
- 8u72-b15-1
- 8u72-b15-2ubuntu1
- 8u72-b15-2ubuntu3
- 8u72-b15-3ubuntu1
- 8u77-b03-1ubuntu2
- 8u77-b03-3ubuntu1
- 8u77-b03-3ubuntu2
- 8u77-b03-3ubuntu3
- 8u91-b14-0ubuntu4~16.04.1
- 8u91-b14-3ubuntu1~16.04.1
- 8u111-b14-2ubuntu0.16.04.2
- 8u121-b13-0ubuntu1.16.04.2
- 8u131-b11-0ubuntu1.16.04.2
- Affected ranges
- ECOSYSTEM: < 8u131-b11-2ubuntu1.16.04.2
Update to 8u131-b11-2ubuntu1.16.04.2
Original sources
- https://access.redhat.com/errata/RHSA-2017:1791
- https://access.redhat.com/errata/RHSA-2017:1790
- https://security.netapp.com/advisory/ntap-20170720-0001/
- https://access.redhat.com/errata/RHSA-2017:1789
- https://cert.vde.com/en-us/advisories/vde-2017-002
- https://access.redhat.com/errata/RHSA-2017:2424
- http://www.securityfocus.com/bid/99734
- http://www.securitytracker.com/id/1038931
- https://access.redhat.com/errata/RHSA-2017:1792
- https://security.gentoo.org/glsa/201709-22
- http://www.debian.org/security/2017/dsa-3919
- https://access.redhat.com/errata/RHSA-2017:2481
- https://access.redhat.com/errata/RHSA-2017:2530
- https://access.redhat.com/errata/RHSA-2017:3453
- https://access.redhat.com/errata/RHSA-2017:2469
- http://www.debian.org/security/2017/dsa-3954
- http://www.oracle.com/technetwork/security-advisory/cpujul2017-3236622.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-10116