p PatchFirst

CVE-2017-10699

CVE-2017-10699

This page contains facts from public vulnerability sources. Check the original advisory before updating.

avcodec 2.2.x, as used in VideoLAN VLC media player 2.2.7-x before 2017-06-29, allows out-of-bounds heap memory write due to calling memcpy() with a wrong size, leading to a denial of service (application crash) or possibly code execution.

CVSS 9.8 · Critical · EPSS 4.5% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • vlc Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.2.6-3

    Update to 2.2.6-3

  • vlc Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.2.6-3

    Update to 2.2.6-3

  • vlc Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.2.6-3

    Update to 2.2.6-3

  • vlc Ubuntu:Pro:14.04:LTS

    Versions
    • 2.0.8-1
    • 2.1.1-1
    • 2.1.2-1
    • 2.1.2-2
    • 2.1.2-2build1
    • 2.1.2-2build2
    • 2.1.4-0ubuntu14.04.1
    • 2.1.6-0ubuntu14.04.1
    • 2.1.6-0ubuntu14.04.2
    • 2.1.6-0ubuntu14.04.3
    • 2.1.6-0ubuntu14.04.4
    • 2.1.6-0ubuntu14.04.5
    Affected ranges
    • ECOSYSTEM: < 2.1.6-0ubuntu14.04.5+esm1

    Update to 2.1.6-0ubuntu14.04.5+esm1

  • vlc Ubuntu:16.04:LTS

    Versions
    • 2.2.1-3
    • 2.2.1-5
    • 2.2.2-1
    • 2.2.2-2
    • 2.2.2-3
    • 2.2.2-3build1
    • 2.2.2-4
    • 2.2.2-5
    • 2.2.2-5ubuntu0.16.04.1
    • 2.2.2-5ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: < 2.2.2-5ubuntu0.16.04.3

    Update to 2.2.2-5ubuntu0.16.04.3

Original sources

Check your server →