p PatchFirst

CVE-2017-10979

CVE-2017-10979

This page contains facts from public vulnerability sources. Check the original advisory before updating.

An FR-GV-202 issue in FreeRADIUS 2.x before 2.2.10 allows "Write overflow in rad_coalesce()" - this allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code.

CVSS 9.8 · Critical · EPSS 7.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • freeradius Debian:12

    Affected ranges
    • ECOSYSTEM: < 3.0.12+dfsg-3

    Update to 3.0.12+dfsg-3

  • freeradius Debian:13

    Affected ranges
    • ECOSYSTEM: < 3.0.12+dfsg-3

    Update to 3.0.12+dfsg-3

  • freeradius Debian:14

    Affected ranges
    • ECOSYSTEM: < 3.0.12+dfsg-3

    Update to 3.0.12+dfsg-3

  • freeradius Ubuntu:14.04:LTS

    Versions
    • 2.1.12+dfsg-1.2ubuntu5
    • 2.1.12+dfsg-1.2ubuntu6
    • 2.1.12+dfsg-1.2ubuntu7
    • 2.1.12+dfsg-1.2ubuntu8
    • 2.1.12+dfsg-1.2ubuntu8.1
    Affected ranges
    • ECOSYSTEM: < 2.1.12+dfsg-1.2ubuntu8.2

    Update to 2.1.12+dfsg-1.2ubuntu8.2

  • freeradius Ubuntu:16.04:LTS

    Versions
    • 2.1.12+dfsg-1.3ubuntu5
    • 2.2.8+dfsg-0.1
    • 2.2.8+dfsg-0.1build1
    • 2.2.8+dfsg-0.1build2
    Affected ranges
    • ECOSYSTEM: < 2.2.8+dfsg-0.1ubuntu0.1

    Update to 2.2.8+dfsg-0.1ubuntu0.1

Original sources

Check your server →