CVE-2017-11185
CVE-2017-11185
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.
CVSS 7.5 · High · EPSS 2.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
strongswan Debian:12
- Affected ranges
- ECOSYSTEM: < 5.6.0-1
Update to 5.6.0-1
strongswan Debian:13
- Affected ranges
- ECOSYSTEM: < 5.6.0-1
Update to 5.6.0-1
strongswan Debian:14
- Affected ranges
- ECOSYSTEM: < 5.6.0-1
Update to 5.6.0-1
strongswan Ubuntu:14.04:LTS
- Versions
- 4.6.4-9
- 5.1.0-2
- 5.1.0-3
- 5.1.1-0ubuntu1
- 5.1.1-0ubuntu2
- 5.1.1-0ubuntu3
- 5.1.1-0ubuntu4
- 5.1.1-0ubuntu5
- 5.1.1-0ubuntu7
- 5.1.1-0ubuntu14
- 5.1.1-0ubuntu17
- 5.1.2~dr3+git20130120-0ubuntu2
- 5.1.2~dr3+git20130120-0ubuntu3
- 5.1.2~rc1-0ubuntu3
- 5.1.2~rc1-0ubuntu4
- 5.1.2~rc2-0ubuntu2
- 5.1.2-0ubuntu1
- 5.1.2-0ubuntu2
- 5.1.2-0ubuntu2.2
- 5.1.2-0ubuntu2.3
- 5.1.2-0ubuntu2.4
- 5.1.2-0ubuntu2.5
- 5.1.2-0ubuntu2.6
- Affected ranges
- ECOSYSTEM: < 5.1.2-0ubuntu2.7
Update to 5.1.2-0ubuntu2.7
strongswan Ubuntu:16.04:LTS
- Versions
- 5.1.2-0ubuntu6
- 5.1.2-0ubuntu7
- 5.1.2-0ubuntu8
- 5.3.5-1ubuntu1
- 5.3.5-1ubuntu2
- 5.3.5-1ubuntu3
- 5.3.5-1ubuntu3.1
- 5.3.5-1ubuntu3.2
- 5.3.5-1ubuntu3.3
- Affected ranges
- ECOSYSTEM: < 5.3.5-1ubuntu3.4
Update to 5.3.5-1ubuntu3.4