p PatchFirst

CVE-2017-12066

CVE-2017-12066

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Cross-site scripting (XSS) vulnerability in aggregate_graphs.php in Cacti before 1.1.16 allows remote authenticated users to inject arbitrary web script or HTML via specially crafted HTTP Referer headers, related to the $cancel_url variable. NOTE: this vulnerability exists because of an incomplete fix (lack of the htmlspecialchars ENT_QUOTES flag) for CVE-2017-11163.

CVSS 5.4 · Medium · EPSS 1.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • cacti Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.1.16+ds1-1

    Update to 1.1.16+ds1-1

  • cacti Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.1.16+ds1-1

    Update to 1.1.16+ds1-1

  • cacti Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.1.16+ds1-1

    Update to 1.1.16+ds1-1

Original sources

Check your server →