CVE-2017-12151
CVE-2017-12151
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in the way samba client before samba 4.4.16, samba 4.5.14 and samba 4.6.8 used encryption with the max protocol set as SMB3. The connection could lose the requirement for signing and encrypting to any DFS redirects, allowing an attacker to read or alter the contents of the connection via a man-in-the-middle attack.
CVSS 7.4 · High · EPSS 4.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
samba
- Versions
- 4.4.16: Affected
- 4.5.14: Affected
- 4.6.8: Affected
No fix published
samba Debian:12
- Affected ranges
- ECOSYSTEM: < 2:4.6.7+dfsg-2
Update to 2:4.6.7+dfsg-2
samba Debian:13
- Affected ranges
- ECOSYSTEM: < 2:4.6.7+dfsg-2
Update to 2:4.6.7+dfsg-2
samba Debian:14
- Affected ranges
- ECOSYSTEM: < 2:4.6.7+dfsg-2
Update to 2:4.6.7+dfsg-2
samba Ubuntu:14.04:LTS
- Versions
- 2:3.6.18-1ubuntu3
- 2:4.0.10+dfsg-4ubuntu2
- 2:4.0.13+dfsg-1ubuntu1
- 2:4.1.3+dfsg-2ubuntu2
- 2:4.1.3+dfsg-2ubuntu3
- 2:4.1.3+dfsg-2ubuntu4
- 2:4.1.3+dfsg-2ubuntu5
- 2:4.1.6+dfsg-1ubuntu1
- 2:4.1.6+dfsg-1ubuntu2
- 2:4.1.6+dfsg-1ubuntu2.14.04.1
- 2:4.1.6+dfsg-1ubuntu2.14.04.2
- 2:4.1.6+dfsg-1ubuntu2.14.04.3
- 2:4.1.6+dfsg-1ubuntu2.14.04.4
- 2:4.1.6+dfsg-1ubuntu2.14.04.5
- 2:4.1.6+dfsg-1ubuntu2.14.04.7
- 2:4.1.6+dfsg-1ubuntu2.14.04.8
- 2:4.1.6+dfsg-1ubuntu2.14.04.9
- 2:4.1.6+dfsg-1ubuntu2.14.04.11
- 2:4.1.6+dfsg-1ubuntu2.14.04.12
- 2:4.1.6+dfsg-1ubuntu2.14.04.13
- 2:4.3.8+dfsg-0ubuntu0.14.04.2
- 2:4.3.9+dfsg-0ubuntu0.14.04.1
- 2:4.3.9+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.1
- 2:4.3.11+dfsg-0ubuntu0.14.04.2
- 2:4.3.11+dfsg-0ubuntu0.14.04.3
- 2:4.3.11+dfsg-0ubuntu0.14.04.4
- 2:4.3.11+dfsg-0ubuntu0.14.04.6
- 2:4.3.11+dfsg-0ubuntu0.14.04.7
- 2:4.3.11+dfsg-0ubuntu0.14.04.8
- 2:4.3.11+dfsg-0ubuntu0.14.04.9
- 2:4.3.11+dfsg-0ubuntu0.14.04.10
- 2:4.3.11+dfsg-0ubuntu0.14.04.11
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.14.04.12
Update to 2:4.3.11+dfsg-0ubuntu0.14.04.12
samba Ubuntu:16.04:LTS
- Versions
- 2:4.1.17+dfsg-4ubuntu2
- 2:4.1.20+dfsg-1ubuntu1
- 2:4.1.20+dfsg-1ubuntu2
- 2:4.1.20+dfsg-1ubuntu3
- 2:4.1.20+dfsg-1ubuntu5
- 2:4.3.3+dfsg-1ubuntu1
- 2:4.3.3+dfsg-1ubuntu2
- 2:4.3.3+dfsg-1ubuntu3
- 2:4.3.6+dfsg-1ubuntu1
- 2:4.3.8+dfsg-0ubuntu1
- 2:4.3.9+dfsg-0ubuntu0.16.04.1
- 2:4.3.9+dfsg-0ubuntu0.16.04.2
- 2:4.3.9+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.1
- 2:4.3.11+dfsg-0ubuntu0.16.04.3
- 2:4.3.11+dfsg-0ubuntu0.16.04.5
- 2:4.3.11+dfsg-0ubuntu0.16.04.6
- 2:4.3.11+dfsg-0ubuntu0.16.04.7
- 2:4.3.11+dfsg-0ubuntu0.16.04.8
- 2:4.3.11+dfsg-0ubuntu0.16.04.9
- 2:4.3.11+dfsg-0ubuntu0.16.04.10
- Affected ranges
- ECOSYSTEM: < 2:4.3.11+dfsg-0ubuntu0.16.04.11
Update to 2:4.3.11+dfsg-0ubuntu0.16.04.11
Original sources
- https://security.netapp.com/advisory/ntap-20170921-0001/
- https://access.redhat.com/errata/RHSA-2017:2790
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-12151
- http://www.securityfocus.com/bid/100917
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03817en_us
- https://www.debian.org/security/2017/dsa-3983
- https://access.redhat.com/errata/RHSA-2017:2858
- http://www.securitytracker.com/id/1039401
- https://www.samba.org/samba/security/CVE-2017-12151.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-12151