p PatchFirst

CVE-2017-12196

CVE-2017-12196

This page contains facts from public vulnerability sources. Check the original advisory before updating.

undertow before versions 1.4.18.SP1, 2.0.2.Final, 1.4.24.Final was found vulnerable when using Digest authentication, the server does not ensure that the value of URI in the Authorization header matches the URI in HTTP request line. This allows the attacker to cause a MITM attack and access the desired content on the server.

CVSS 4.8 · Medium · EPSS 2.0% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • undertow

    Versions
    • undertow 1.4.18.SP1: Affected
    • undertow 2.0.2.Final: Affected
    • undertow 1.4.24.Final: Affected

    No fix published

  • undertow Debian:14

    Versions
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.19-1
    • 1.3.21-1
    • 1.3.23-1
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.4.0-1
    • 1.4.1-1
    • 1.4.18-1
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.21-2
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2
    • 1.4.23-3
    • 1.4.3-1
    • 1.4.4-1
    • 1.4.6-1
    • 1.4.7-1
    • 1.4.8-1
    Affected ranges
    • ECOSYSTEM: < 1.4.25-1

    Update to 1.4.25-1

  • undertow Ubuntu:Pro:16.04:LTS

    Versions
    • 1.3.4-1
    • 1.3.5-1
    • 1.3.7-1
    • 1.3.11-1
    • 1.3.16-1
    • 1.3.16-1ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • undertow Ubuntu:Pro:18.04:LTS

    Versions
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.22-1
    • 1.4.23-1
    • 1.4.23-2build1
    • 1.4.23-3
    • 1.4.23-3ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

  • undertow Ubuntu:Pro:24.04:LTS

    Versions
    • 2.3.8-2
    • 2.3.8-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →