p PatchFirst

CVE-2017-12378

CVE-2017-12378

This page contains facts from public vulnerability sources. Check the original advisory before updating.

ClamAV AntiVirus software versions 0.99.2 and prior contain a vulnerability that could allow an unauthenticated, remote attacker to cause a denial of service (DoS) condition on an affected device. The vulnerability is due to improper input validation checking mechanisms of .tar (Tape Archive) files sent to an affected device. A successful exploit could cause a checksum buffer over-read condition when ClamAV scans the malicious .tar file, potentially allowing the attacker to cause a DoS condition on the affected device.

CVSS 5.5 · Medium · EPSS 2.8% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • clamav antivirus software versions 0.99.2 and prior

    Versions
    • ClamAV AntiVirus software versions 0.99.2 and prior: Affected

    No fix published

  • clamav Debian:12

    Affected ranges
    • ECOSYSTEM: < 0.99.3~beta2+dfsg-1

    Update to 0.99.3~beta2+dfsg-1

  • clamav Debian:13

    Affected ranges
    • ECOSYSTEM: < 0.99.3~beta2+dfsg-1

    Update to 0.99.3~beta2+dfsg-1

  • clamav Debian:14

    Affected ranges
    • ECOSYSTEM: < 0.99.3~beta2+dfsg-1

    Update to 0.99.3~beta2+dfsg-1

  • clamav Ubuntu:14.04:LTS

    Versions
    • 0.97.8+dfsg-1ubuntu4
    • 0.97.8+dfsg-1ubuntu5
    • 0.98.1+dfsg-1ubuntu4
    • 0.98.1+dfsg-1ubuntu5
    • 0.98.1+dfsg-2ubuntu2
    • 0.98.1+dfsg-4ubuntu1
    • 0.98.1+dfsg-4ubuntu1.1
    • 0.98.5+addedllvm-0ubuntu0.14.04.1
    • 0.98.6+dfsg-0ubuntu0.14.04.1
    • 0.98.7+dfsg-0ubuntu0.14.04.1
    • 0.99.2+addedllvm-0ubuntu0.14.04.1
    • 0.99.2+addedllvm-0ubuntu0.14.04.2
    Affected ranges
    • ECOSYSTEM: < 0.99.3+addedllvm-0ubuntu0.14.04.1

    Update to 0.99.3+addedllvm-0ubuntu0.14.04.1

  • clamav Ubuntu:16.04:LTS

    Versions
    • 0.98.7+dfsg-0ubuntu4
    • 0.98.7+dfsg-0ubuntu5
    • 0.99+dfsg-1ubuntu1
    • 0.99+dfsg-1ubuntu1.1
    • 0.99+dfsg-1ubuntu1.2
    • 0.99.2+dfsg-0ubuntu0.16.04.1
    • 0.99.2+dfsg-0ubuntu0.16.04.2
    • 0.99.2+dfsg-0ubuntu0.16.04.3
    Affected ranges
    • ECOSYSTEM: < 0.99.3+addedllvm-0ubuntu0.16.04.1

    Update to 0.99.3+addedllvm-0ubuntu0.16.04.1

Original sources

Check your server →