CVE-2017-12596
CVE-2017-12596
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In OpenEXR 2.2.0, a crafted image causes a heap-based buffer over-read in the hufDecode function in IlmImf/ImfHuf.cpp during exrmaketiled execution; it may result in denial of service or possibly unspecified other impact.
CVSS 7.8 · High · EPSS 1.9% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
openexr Debian:12
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1
Update to 2.2.0-11.1
openexr Debian:13
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1
Update to 2.2.0-11.1
openexr Debian:14
- Affected ranges
- ECOSYSTEM: < 2.2.0-11.1
Update to 2.2.0-11.1
openexr Ubuntu:16.04:LTS
- Versions
- 2.2.0-1ubuntu3
- 2.2.0-7ubuntu1
- 2.2.0-9ubuntu1
- 2.2.0-10ubuntu2
- Affected ranges
- ECOSYSTEM: < 2.2.0-10ubuntu2.1
Update to 2.2.0-10ubuntu2.1