CVE-2017-12791
CVE-2017-12791
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Directory traversal vulnerability in minion id validation in SaltStack Salt before 2016.11.7 and 2017.7.x before 2017.7.1 allows remote minions with incorrect credentials to authenticate to a master via a crafted minion ID.
CVSS 9.8 · Critical · EPSS 4.7% · Fix available
- Published
- Updated
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
salt PyPI
- Versions
- 0.10.0
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.10.5
- 0.11.0
- 0.11.1
- 0.12.0
- 0.12.1
- 0.13.0
- 0.13.1
- 0.13.2
- 0.13.3
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.90
- 0.16.0
- 0.16.1
- 0.16.2
- 0.16.3
- 0.16.4
- 0.17.0
- 0.17.0rc1
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.17.5
- 0.8.7
- 0.8.9
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 0.9.9.1
- 2014.1.0
- 2014.1.0rc1
- 2014.1.0rc2
- 2014.1.0rc3
- 2014.1.1
- 2014.1.10
- 2014.1.11
- 2014.1.12
- 2014.1.13
- 2014.1.2
- 2014.1.3
- 2014.1.4
- 2014.1.5
- 2014.1.6
- 2014.1.7
- 2014.1.8
- 2014.1.9
- 2014.7.0
- 2014.7.0rc1
- 2014.7.0rc2
- 2014.7.0rc3
- 2014.7.0rc4
- 2014.7.0rc5
- 2014.7.0rc6
- 2014.7.0rc7
- 2014.7.1
- 2014.7.2
- 2014.7.3
- 2014.7.4
- 2014.7.5
- 2014.7.6
- 2014.7.7
- 2015.2.0rc1
- 2015.2.0rc2
- 2015.5.0
- 2015.5.1
- 2015.5.10
- 2015.5.11
- 2015.5.2
- 2015.5.3
- 2015.5.4
- 2015.5.5
- 2015.5.6
- 2015.5.7
- 2015.5.8
- 2015.5.9
- 2015.8.0
- 2015.8.0rc1
- 2015.8.0rc2
- 2015.8.0rc3
- 2015.8.0rc4
- 2015.8.0rc5
- 2015.8.1
- 2015.8.10
- 2015.8.11
- 2015.8.12
- 2015.8.13
- 2015.8.2
- 2015.8.3
- 2015.8.4
- 2015.8.5
- 2015.8.7
- 2015.8.8
- 2015.8.8.2
- 2015.8.9
- 2016.11.0
- 2016.11.0rc1
- 2016.11.0rc2
- 2016.11.1
- 2016.11.2
- 2016.11.3
- 2016.11.4
- 2016.11.5
- 2016.11.6
- 2016.3.0
- 2016.3.0rc2
- 2016.3.0rc3
- 2016.3.1
- 2016.3.2
- 2016.3.3
- 2016.3.4
- 2016.3.5
- 2016.3.6
- 2016.3.7
- 2016.3.8
- Affected ranges
- ECOSYSTEM: < 2016.11.7
Update to 2016.11.7
salt PyPI
- Versions
- 2017.7.0
- Affected ranges
- ECOSYSTEM: ≥ 2017.7.0, < 2017.7.1
Update to 2017.7.1
salt PyPI
- Versions
- 0.10.0
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.10.5
- 0.11.0
- 0.11.1
- 0.12.0
- 0.12.1
- 0.13.0
- 0.13.1
- 0.13.2
- 0.13.3
- 0.14.0
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.90
- 0.16.0
- 0.16.1
- 0.16.2
- 0.16.3
- 0.16.4
- 0.17.0
- 0.17.0rc1
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.17.5
- 0.8.7
- 0.8.9
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 0.9.9.1
- 2014.1.0
- 2014.1.0rc1
- 2014.1.0rc2
- 2014.1.0rc3
- 2014.1.1
- 2014.1.10
- 2014.1.11
- 2014.1.12
- 2014.1.13
- 2014.1.2
- 2014.1.3
- 2014.1.4
- 2014.1.5
- 2014.1.6
- 2014.1.7
- 2014.1.8
- 2014.1.9
- 2014.7.0
- 2014.7.0rc1
- 2014.7.0rc2
- 2014.7.0rc3
- 2014.7.0rc4
- 2014.7.0rc5
- 2014.7.0rc6
- 2014.7.0rc7
- 2014.7.1
- 2014.7.2
- 2014.7.3
- 2014.7.4
- 2014.7.5
- 2014.7.6
- 2014.7.7
- 2015.2.0rc1
- 2015.2.0rc2
- 2015.5.0
- 2015.5.1
- 2015.5.10
- 2015.5.11
- 2015.5.2
- 2015.5.3
- 2015.5.4
- 2015.5.5
- 2015.5.6
- 2015.5.7
- 2015.5.8
- 2015.5.9
- 2015.8.0
- 2015.8.0rc1
- 2015.8.0rc2
- 2015.8.0rc3
- 2015.8.0rc4
- 2015.8.0rc5
- 2015.8.1
- 2015.8.10
- 2015.8.11
- 2015.8.12
- 2015.8.13
- 2015.8.2
- 2015.8.3
- 2015.8.4
- 2015.8.5
- 2015.8.7
- 2015.8.8
- 2015.8.8.2
- 2015.8.9
- 2016.11.0
- 2016.11.0rc1
- 2016.11.0rc2
- 2016.11.1
- 2016.11.2
- 2016.11.3
- 2016.11.4
- 2016.11.5
- 2016.11.6
- 2016.3.0
- 2016.3.0rc2
- 2016.3.0rc3
- 2016.3.1
- 2016.3.2
- 2016.3.3
- 2016.3.4
- 2016.3.5
- 2016.3.6
- 2016.3.7
- 2016.3.8
- 2017.7.0
- Affected ranges
- ECOSYSTEM: < 2016.11.7 ∪ ≥ 2017.7, < 2017.7.1
Update to 2016.11.7; Update to 2017.7.1
salt Ubuntu:Pro:14.04:LTS
- Versions
- 0.16.0-1
- 0.16.4-2
- 0.17.1+dfsg-1
- 0.17.2-1
- 0.17.2-2
- 0.17.2-3
- 0.17.4-1
- 0.17.4-2
- 0.17.5-1
- 0.17.5+ds-1
- Affected ranges
- ECOSYSTEM: < 0.17.5+ds-1ubuntu0.1~esm1
Update to 0.17.5+ds-1ubuntu0.1~esm1
salt Ubuntu:Pro:16.04:LTS
- Versions
- 2015.5.3+ds-1
- 2015.8.1+ds-2
- 2015.8.3+ds-1
- 2015.8.3+ds-2
- 2015.8.3+ds-3
- 2015.8.5+ds-1
- 2015.8.7+ds-1
- 2015.8.8+ds-1
- 2015.8.8+ds-1ubuntu0.1~esm1
- 2015.8.8+ds-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 2015.8.8+ds-1ubuntu0.1+esm1
Update to 2015.8.8+ds-1ubuntu0.1+esm1
Original sources
- https://github.com/saltstack/salt/pull/42944
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=872399
- http://www.securityfocus.com/bid/100384
- https://bugzilla.redhat.com/show_bug.cgi?id=1482006
- https://docs.saltstack.com/en/latest/topics/releases/2017.7.1.html
- https://docs.saltstack.com/en/2016.11/topics/releases/2016.11.7.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-12791