CVE-2017-12932
CVE-2017-12932
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ext/standard/var_unserializer.re in PHP 7.0.x through 7.0.22 and 7.1.x through 7.1.8 is prone to a heap use after free while unserializing untrusted data, related to improper use of the hash API for key deletion in a situation with an invalid array size. Exploitation of this issue can have an unspecified impact on the integrity of PHP.
CVSS 9.8 · Critical · EPSS 7.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
php7.0 Ubuntu:16.04:LTS
- Versions
- 7.0.1-5
- 7.0.1-6
- 7.0.2-1
- 7.0.2-3
- 7.0.2-4
- 7.0.2-5
- 7.0.3-2
- 7.0.3-3
- 7.0.3-9ubuntu1
- 7.0.4-5ubuntu1
- 7.0.4-5ubuntu2
- 7.0.4-7ubuntu1
- 7.0.4-7ubuntu2
- 7.0.4-7ubuntu2.1
- 7.0.8-0ubuntu0.16.04.1
- 7.0.8-0ubuntu0.16.04.2
- 7.0.8-0ubuntu0.16.04.3
- 7.0.13-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.1
- 7.0.15-0ubuntu0.16.04.2
- 7.0.15-0ubuntu0.16.04.4
- 7.0.18-0ubuntu0.16.04.1
- 7.0.22-0ubuntu0.16.04.1
- Affected ranges
- ECOSYSTEM: < 7.0.25-0ubuntu0.16.04.1
Update to 7.0.25-0ubuntu0.16.04.1
Original sources
- http://www.securityfocus.com/bid/100427
- https://access.redhat.com/errata/RHSA-2018:1296
- https://github.com/php/php-src/commit/1a23ebc1fff59bf480ca92963b36eba5c1b904c4
- https://security.netapp.com/advisory/ntap-20180112-0001/
- https://bugs.php.net/bug.php?id=74103
- https://www.debian.org/security/2018/dsa-4080
- http://php.net/ChangeLog-7.php
- https://security.gentoo.org/glsa/201709-21
- https://access.redhat.com/errata/RHSA-2019:2519
- https://nvd.nist.gov/vuln/detail/CVE-2017-12932