CVE-2017-13721
CVE-2017-13721
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In X.Org Server (aka xserver and xorg-server) before 1.19.4, an attacker authenticated to an X server with the X shared memory extension enabled can cause aborts of the X server or replace shared memory segments of other X clients in the same session.
CVSS 4.7 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xorg-server Debian:12
- Affected ranges
- ECOSYSTEM: < 2:1.19.4-1
Update to 2:1.19.4-1
xorg-server Debian:13
- Affected ranges
- ECOSYSTEM: < 2:1.19.4-1
Update to 2:1.19.4-1
xorg-server Debian:14
- Affected ranges
- ECOSYSTEM: < 2:1.19.4-1
Update to 2:1.19.4-1
xorg-server Ubuntu:14.04:LTS
- Versions
- 2:1.14.3-3ubuntu2
- 2:1.14.3-3ubuntu3
- 2:1.14.3-3ubuntu4
- 2:1.14.3-5ubuntu1
- 2:1.14.4-1ubuntu1
- 2:1.14.4-1ubuntu2
- 2:1.14.4.901-0ubuntu2
- 2:1.14.5-1ubuntu2
- 2:1.14.5-1ubuntu4
- 2:1.15.0-1ubuntu1
- 2:1.15.0-1ubuntu2
- 2:1.15.0-1ubuntu3
- 2:1.15.0-1ubuntu4
- 2:1.15.0-1ubuntu6
- 2:1.15.0-1ubuntu7
- 2:1.15.1-0ubuntu1
- 2:1.15.1-0ubuntu2
- 2:1.15.1-0ubuntu2.1
- 2:1.15.1-0ubuntu2.4
- 2:1.15.1-0ubuntu2.5
- 2:1.15.1-0ubuntu2.6
- 2:1.15.1-0ubuntu2.7
- 2:1.15.1-0ubuntu2.9
- Affected ranges
- ECOSYSTEM: < 2:1.15.1-0ubuntu2.10
Update to 2:1.15.1-0ubuntu2.10
xorg-server-lts-xenial Ubuntu:14.04:LTS
- Versions
- 2:1.18.3-1ubuntu2.2~trusty1
- 2:1.18.3-1ubuntu2.2~trusty2
- 2:1.18.3-1ubuntu2.2~trusty3
- 2:1.18.3-1ubuntu2.3~trusty1
- 2:1.18.3-1ubuntu2.3~trusty2
- Affected ranges
- ECOSYSTEM: < 2:1.18.3-1ubuntu2.3~trusty3
Update to 2:1.18.3-1ubuntu2.3~trusty3
xorg-server Ubuntu:16.04:LTS
- Versions
- 2:1.17.2-1ubuntu9
- 2:1.17.2-1ubuntu10
- 2:1.17.3-2ubuntu1
- 2:1.17.3-2ubuntu2
- 2:1.17.3-2ubuntu3
- 2:1.17.3-2ubuntu4
- 2:1.18.1-1ubuntu3
- 2:1.18.1-1ubuntu4
- 2:1.18.3-1ubuntu1
- 2:1.18.3-1ubuntu2
- 2:1.18.3-1ubuntu2.2
- 2:1.18.3-1ubuntu2.3
- 2:1.18.4-0ubuntu0.1
- 2:1.18.4-0ubuntu0.2
- 2:1.18.4-0ubuntu0.3
- 2:1.18.4-0ubuntu0.4
- Affected ranges
- ECOSYSTEM: < 2:1.18.4-0ubuntu0.6
Update to 2:1.18.4-0ubuntu0.6
xorg-server-hwe-16.04 Ubuntu:16.04:LTS
- Versions
- 2:1.18.4-1ubuntu6.1~16.04.1
- 2:1.18.4-1ubuntu6.1~16.04.2
- 2:1.19.3-1ubuntu1~16.04.2
- Affected ranges
- ECOSYSTEM: < 2:1.19.3-1ubuntu1~16.04.3
Update to 2:1.19.3-1ubuntu1~16.04.3
Original sources
- https://cgit.freedesktop.org/xorg/xserver/commit/?id=b95f25af141d33a65f6f821ea9c003f66a01e1f1
- https://security.gentoo.org/glsa/201710-30
- http://www.openwall.com/lists/oss-security/2017/10/04/10
- http://www.securityfocus.com/bid/101238
- http://www.debian.org/security/2017/dsa-4000
- https://lists.x.org/archives/xorg-announce/2017-October/002808.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-13721