CVE-2017-14227
CVE-2017-14227
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In MongoDB libbson 1.7.0, the bson_iter_codewscope function in bson-iter.c miscalculates a bson_utf8_validate length argument, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the bson_utf8_validate function in bson-utf8.c), as demonstrated by bson-to-json.c.
CVSS 7.5 · High · EPSS 5.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libbson-xs-perl Debian:12
- Versions
- 0.8.4-2
- Affected ranges
- ECOSYSTEM: < 0.8.4-2+deb12u1
Update to 0.8.4-2+deb12u1
libbson Ubuntu:Pro:16.04:LTS
- Versions
- 1.3.1-1
- Affected ranges
- ECOSYSTEM: < 1.3.1-1ubuntu0.1~esm1
Update to 1.3.1-1ubuntu0.1~esm1
Original sources
- https://bugzilla.redhat.com/show_bug.cgi?id=1489362
- http://www.securityfocus.com/bid/100825
- https://bugzilla.redhat.com/show_bug.cgi?id=1489355
- https://bugzilla.redhat.com/show_bug.cgi?id=1489356
- https://lists.debian.org/debian-lts-announce/2025/05/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2017-14227