p PatchFirst

CVE-2017-14314

CVE-2017-14314

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Off-by-one error in the DrawImage function in magick/render.c in GraphicsMagick 1.3.26 allows remote attackers to cause a denial of service (DrawDashPolygon heap-based buffer over-read and application crash) via a crafted file.

CVSS 6.5 · Medium · EPSS 1.9% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • graphicsmagick Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.3.26-10

    Update to 1.3.26-10

  • graphicsmagick Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.3.26-10

    Update to 1.3.26-10

  • graphicsmagick Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.3.26-10

    Update to 1.3.26-10

  • graphicsmagick Ubuntu:Pro:14.04:LTS

    Versions
    • 1.3.16-1.1ubuntu2
    • 1.3.16-1.1ubuntu3
    • 1.3.18-1ubuntu3
    • 1.3.18-1ubuntu3.1
    • 1.3.18-1ubuntu3.1+esm1
    • 1.3.18-1ubuntu3.1+esm2
    • 1.3.18-1ubuntu3.1+esm3
    Affected ranges
    • ECOSYSTEM: < 1.3.18-1ubuntu3.1+esm4

    Update to 1.3.18-1ubuntu3.1+esm4

  • graphicsmagick Ubuntu:16.04:LTS

    Versions
    • 1.3.21-3
    • 1.3.23-1
    • 1.3.23-1build1
    • 1.3.23-1ubuntu0.1
    • 1.3.23-1ubuntu0.2
    • 1.3.23-1ubuntu0.3
    Affected ranges
    • ECOSYSTEM: < 1.3.23-1ubuntu0.4

    Update to 1.3.23-1ubuntu0.4

Original sources

Check your server →