CVE-2017-14316
CVE-2017-14316
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A parameter verification issue was discovered in Xen through 4.9.x. The function `alloc_heap_pages` allows callers to specify the first NUMA node that should be used for allocations through the `memflags` parameter; the node is extracted using the `MEMF_get_node` macro. While the function checks to see if the special constant `NUMA_NO_NODE` is specified, it otherwise does not handle the case where `node >= MAX_NUMNODES`. This allows an out-of-bounds access to an internal array.
CVSS 8.8 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Ubuntu:14.04:LTS
- Versions
- 4.3.0-1ubuntu1
- 4.3.0-1ubuntu2
- 4.3.0-1ubuntu3
- 4.3.0-1ubuntu4
- 4.3.0-1ubuntu5
- 4.4.0-0ubuntu3
- 4.4.0-0ubuntu4
- 4.4.0-0ubuntu5
- 4.4.0-0ubuntu5.1
- 4.4.0-0ubuntu5.2
- 4.4.1-0ubuntu0.14.04.1
- 4.4.1-0ubuntu0.14.04.2
- 4.4.1-0ubuntu0.14.04.3
- 4.4.1-0ubuntu0.14.04.4
- 4.4.1-0ubuntu0.14.04.5
- 4.4.1-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.1
- 4.4.2-0ubuntu0.14.04.2
- 4.4.2-0ubuntu0.14.04.3
- 4.4.2-0ubuntu0.14.04.4
- 4.4.2-0ubuntu0.14.04.5
- 4.4.2-0ubuntu0.14.04.6
- 4.4.2-0ubuntu0.14.04.7
- 4.4.2-0ubuntu0.14.04.9
- 4.4.2-0ubuntu0.14.04.10
- 4.4.2-0ubuntu0.14.04.11
- 4.4.2-0ubuntu0.14.04.12
- Affected ranges
- ECOSYSTEM: < 4.4.2-0ubuntu0.14.04.14
Update to 4.4.2-0ubuntu0.14.04.14
xen Ubuntu:16.04:LTS
- Versions
- 4.5.1-0ubuntu1
- 4.5.1-0ubuntu2
- 4.6.0-1ubuntu1
- 4.6.0-1ubuntu2
- 4.6.0-1ubuntu4
- 4.6.0-1ubuntu4.1
- 4.6.0-1ubuntu4.2
- 4.6.0-1ubuntu4.3
- 4.6.5-0ubuntu1
- 4.6.5-0ubuntu1.1
- 4.6.5-0ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 4.6.5-0ubuntu1.4
Update to 4.6.5-0ubuntu1.4
Original sources
- http://www.securityfocus.com/bid/100818
- http://xenbits.xen.org/xsa/advisory-231.html
- https://support.citrix.com/article/CTX227185
- https://www.debian.org/security/2017/dsa-4050
- https://lists.debian.org/debian-lts-announce/2018/10/msg00009.html
- http://www.securitytracker.com/id/1039348
- https://nvd.nist.gov/vuln/detail/CVE-2017-14316