p PatchFirst

CVE-2017-14493

CVE-2017-14493

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Stack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted DHCPv6 request.

CVSS 9.8 · Critical · EPSS 85.2% · Public exploit · Fix available

Published
Updated

Stack: system

Affected products and versions

  • n/a

    Versions
    • n/a: Affected

    No fix published

  • dnsmasq Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.78-1

    Update to 2.78-1

  • dnsmasq Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.78-1

    Update to 2.78-1

  • dnsmasq Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.78-1

    Update to 2.78-1

  • dnsmasq Ubuntu:14.04:LTS

    Versions
    • 2.66-4ubuntu1
    • 2.67-1
    • 2.68-1
    • 2.68-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 2.68-1ubuntu0.2

    Update to 2.68-1ubuntu0.2

  • dnsmasq Ubuntu:16.04:LTS

    Versions
    • 2.75-1
    • 2.75-1ubuntu0.16.04.1
    • 2.75-1ubuntu0.16.04.2
    Affected ranges
    • ECOSYSTEM: < 2.75-1ubuntu0.16.04.3

    Update to 2.75-1ubuntu0.16.04.3

Original sources

Check your server →