CVE-2017-14723
CVE-2017-14723
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Before version 4.8.2, WordPress mishandled % characters and additional placeholder values in $wpdb->prepare, and thus did not properly address the possibility of plugins and themes enabling SQL injection attacks.
CVSS 9.8 · Critical · EPSS 6.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
wordpress Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.2+dfsg-1
Update to 4.8.2+dfsg-1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.2+dfsg-1
Update to 4.8.2+dfsg-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.2+dfsg-1
Update to 4.8.2+dfsg-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://www.debian.org/security/2017/dsa-3997
- https://medium.com/websec/wordpress-sqli-poc-f1827c20bf8e
- http://www.securityfocus.com/bid/100912
- http://www.securitytracker.com/id/1039553
- https://github.com/WordPress/WordPress/commit/fc930d3daed1c3acef010d04acc2c5de93cd18ec
- https://core.trac.wordpress.org/changeset/41470
- https://core.trac.wordpress.org/changeset/41496
- https://wordpress.org/news/2017/09/wordpress-4-8-2-security-and-maintenance-release/
- https://medium.com/websec/wordpress-sqli-bbb2afcc8e94
- https://github.com/WordPress/WordPress/commit/70b21279098fc973eae803693c0705a548128e48
- https://nvd.nist.gov/vuln/detail/CVE-2017-14723