CVE-2017-14733
CVE-2017-14733
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ReadRLEImage in coders/rle.c in GraphicsMagick 1.3.26 mishandles RLE headers that specify too few colors, which allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted file.
CVSS 6.5 · Medium · EPSS 2.1% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
graphicsmagick Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.26-13
Update to 1.3.26-13
graphicsmagick Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.26-13
Update to 1.3.26-13
graphicsmagick Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.26-13
Update to 1.3.26-13
graphicsmagick Ubuntu:16.04:LTS
- Versions
- 1.3.21-3
- 1.3.23-1
- 1.3.23-1build1
- 1.3.23-1ubuntu0.1
- 1.3.23-1ubuntu0.2
- 1.3.23-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.3.23-1ubuntu0.4
Update to 1.3.23-1ubuntu0.4
Original sources
- https://www.debian.org/security/2018/dsa-4321
- http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset%3Bnode=5381c71724e3
- https://lists.debian.org/debian-lts-announce/2018/06/msg00009.html
- https://sourceforge.net/p/graphicsmagick/bugs/458/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PF62B5PJA2JDUOCKJGUQO3SPL74BEYSV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WHIKB4TP6KBJWT2UIPWL5MWMG5QXKGEJ/
- https://usn.ubuntu.com/4232-1/
- https://nvd.nist.gov/vuln/detail/CVE-2017-14733