CVE-2017-15038
CVE-2017-15038
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Race condition in the v9fs_xattrwalk function in hw/9pfs/9p.c in QEMU (aka Quick Emulator) allows local guest OS users to obtain sensitive information from host heap memory via vectors related to reading extended attributes.
CVSS 5.6 · Medium · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
qemu Debian:12
- Affected ranges
- ECOSYSTEM: < 1:2.10.0+dfsg-2
Update to 1:2.10.0+dfsg-2
qemu Debian:13
- Affected ranges
- ECOSYSTEM: < 1:2.10.0+dfsg-2
Update to 1:2.10.0+dfsg-2
qemu Debian:14
- Affected ranges
- ECOSYSTEM: < 1:2.10.0+dfsg-2
Update to 1:2.10.0+dfsg-2
qemu Ubuntu:14.04:LTS
- Versions
- 1.5.0+dfsg-3ubuntu5
- 1.5.0+dfsg-3ubuntu6
- 1.6.0+dfsg-2ubuntu1
- 1.6.0+dfsg-2ubuntu2
- 1.6.0+dfsg-2ubuntu3
- 1.6.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu1
- 1.7.0+dfsg-2ubuntu2
- 1.7.0+dfsg-2ubuntu3
- 1.7.0+dfsg-2ubuntu4
- 1.7.0+dfsg-2ubuntu5
- 1.7.0+dfsg-2ubuntu7
- 1.7.0+dfsg-2ubuntu8
- 1.7.0+dfsg-2ubuntu9
- 1.7.0+dfsg-3ubuntu1~ppa1
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- 1.7.0+dfsg-3ubuntu3
- 1.7.0+dfsg-3ubuntu4
- 1.7.0+dfsg-3ubuntu5
- 1.7.0+dfsg-3ubuntu6
- 1.7.0+dfsg-3ubuntu7
- 2.0.0~rc1+dfsg-0ubuntu1
- 2.0.0~rc1+dfsg-0ubuntu2
- 2.0.0~rc1+dfsg-0ubuntu3
- 2.0.0~rc1+dfsg-0ubuntu3.1
- 2.0.0+dfsg-2ubuntu1
- 2.0.0+dfsg-2ubuntu1.1
- 2.0.0+dfsg-2ubuntu1.2
- 2.0.0+dfsg-2ubuntu1.3
- 2.0.0+dfsg-2ubuntu1.5
- 2.0.0+dfsg-2ubuntu1.6
- 2.0.0+dfsg-2ubuntu1.7
- 2.0.0+dfsg-2ubuntu1.8
- 2.0.0+dfsg-2ubuntu1.9
- 2.0.0+dfsg-2ubuntu1.10
- 2.0.0+dfsg-2ubuntu1.11
- 2.0.0+dfsg-2ubuntu1.13
- 2.0.0+dfsg-2ubuntu1.14
- 2.0.0+dfsg-2ubuntu1.15
- 2.0.0+dfsg-2ubuntu1.16
- 2.0.0+dfsg-2ubuntu1.17
- 2.0.0+dfsg-2ubuntu1.18
- 2.0.0+dfsg-2ubuntu1.19
- 2.0.0+dfsg-2ubuntu1.20
- 2.0.0+dfsg-2ubuntu1.21
- 2.0.0+dfsg-2ubuntu1.22
- 2.0.0+dfsg-2ubuntu1.24
- 2.0.0+dfsg-2ubuntu1.25
- 2.0.0+dfsg-2ubuntu1.26
- 2.0.0+dfsg-2ubuntu1.27
- 2.0.0+dfsg-2ubuntu1.28
- 2.0.0+dfsg-2ubuntu1.29
- 2.0.0+dfsg-2ubuntu1.30
- 2.0.0+dfsg-2ubuntu1.31
- 2.0.0+dfsg-2ubuntu1.32
- 2.0.0+dfsg-2ubuntu1.33
- 2.0.0+dfsg-2ubuntu1.34
- 2.0.0+dfsg-2ubuntu1.35
- 2.0.0+dfsg-2ubuntu1.36
- 2.0.0+dfsg-2ubuntu1.38
- Affected ranges
- ECOSYSTEM: < 2.0.0+dfsg-2ubuntu1.39
Update to 2.0.0+dfsg-2ubuntu1.39
qemu Ubuntu:16.04:LTS
- Versions
- 1:2.3+dfsg-5ubuntu9
- 1:2.3+dfsg-5ubuntu10
- 1:2.4+dfsg-4ubuntu1
- 1:2.4+dfsg-4ubuntu2
- 1:2.4+dfsg-4ubuntu3
- 1:2.4+dfsg-5ubuntu3
- 1:2.5+dfsg-1ubuntu2
- 1:2.5+dfsg-1ubuntu3
- 1:2.5+dfsg-1ubuntu4
- 1:2.5+dfsg-1ubuntu5
- 1:2.5+dfsg-5ubuntu1
- 1:2.5+dfsg-5ubuntu2
- 1:2.5+dfsg-5ubuntu4
- 1:2.5+dfsg-5ubuntu6
- 1:2.5+dfsg-5ubuntu7
- 1:2.5+dfsg-5ubuntu10
- 1:2.5+dfsg-5ubuntu10.1
- 1:2.5+dfsg-5ubuntu10.2
- 1:2.5+dfsg-5ubuntu10.3
- 1:2.5+dfsg-5ubuntu10.4
- 1:2.5+dfsg-5ubuntu10.5
- 1:2.5+dfsg-5ubuntu10.6
- 1:2.5+dfsg-5ubuntu10.7
- 1:2.5+dfsg-5ubuntu10.8
- 1:2.5+dfsg-5ubuntu10.9
- 1:2.5+dfsg-5ubuntu10.10
- 1:2.5+dfsg-5ubuntu10.11
- 1:2.5+dfsg-5ubuntu10.13
- 1:2.5+dfsg-5ubuntu10.14
- 1:2.5+dfsg-5ubuntu10.15
- 1:2.5+dfsg-5ubuntu10.16
- 1:2.5+dfsg-5ubuntu10.20
- 1:2.5+dfsg-5ubuntu10.21
- Affected ranges
- ECOSYSTEM: < 1:2.5+dfsg-5ubuntu10.22
Update to 1:2.5+dfsg-5ubuntu10.22
Original sources
- https://lists.debian.org/debian-lts-announce/2018/09/msg00007.html
- https://www.debian.org/security/2018/dsa-4213
- https://lists.gnu.org/archive/html/qemu-devel/2017-10/msg00729.html
- https://usn.ubuntu.com/3575-1/
- http://www.openwall.com/lists/oss-security/2017/10/06/1
- https://nvd.nist.gov/vuln/detail/CVE-2017-15038