CVE-2017-15091
CVE-2017-15091
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue has been found in the API component of PowerDNS Authoritative 4.x up to and including 4.0.4 and 3.x up to and including 3.4.11, where some operations that have an impact on the state of the server are still allowed even though the API has been configured as read-only via the api-readonly keyword. This missing check allows an attacker with valid API credentials to flush the cache, trigger a zone transfer or send a NOTIFY.
CVSS 7.1 · High · EPSS 1.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
powerdns authoritative
- Versions
- 4.x up to and including 4.0.4: Affected
- 3.x up to and including 3.4.11: Affected
No fix published
pdns Debian:12
- Affected ranges
- ECOSYSTEM: < 4.0.5-1
Update to 4.0.5-1
pdns Debian:13
- Affected ranges
- ECOSYSTEM: < 4.0.5-1
Update to 4.0.5-1
pdns Debian:14
- Affected ranges
- ECOSYSTEM: < 4.0.5-1
Update to 4.0.5-1
pdns Ubuntu:Pro:16.04:LTS
- Versions
- 3.4.5-1build2
- 3.4.6-2
- 3.4.6-3
- 3.4.7-1
- 3.4.7-2
- 4.0.0~alpha1-1
- 4.0.0~alpha2-2
- 4.0.0~alpha2-3
- 4.0.0~alpha2-3build1
- 4.0.0~alpha2-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published