p PatchFirst

CVE-2017-15105

CVE-2017-15105

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound into accepting a NODATA proof.

CVSS 5.3 · Medium · EPSS 3.2% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • unbound

    Versions
    • before 1.6.8: Affected

    No fix published

  • unbound Debian:12

    Affected ranges
    • ECOSYSTEM: < 1.7.1-1

    Update to 1.7.1-1

  • unbound Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.7.1-1

    Update to 1.7.1-1

  • unbound Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.7.1-1

    Update to 1.7.1-1

  • unbound Ubuntu:14.04:LTS

    Versions
    • 1.4.20-1
    • 1.4.21-1
    • 1.4.21-1ubuntu1
    • 1.4.21-1ubuntu2
    • 1.4.22-1ubuntu1
    • 1.4.22-1ubuntu2
    • 1.4.22-1ubuntu3
    • 1.4.22-1ubuntu4
    • 1.4.22-1ubuntu4.14.04.1
    • 1.4.22-1ubuntu4.14.04.2
    Affected ranges
    • ECOSYSTEM: < 1.4.22-1ubuntu4.14.04.3

    Update to 1.4.22-1ubuntu4.14.04.3

  • unbound Ubuntu:16.04:LTS

    Versions
    • 1.4.22-1ubuntu6
    • 1.5.7-1ubuntu1
    • 1.5.7-1ubuntu2
    • 1.5.8-1ubuntu1
    Affected ranges
    • ECOSYSTEM: < 1.5.8-1ubuntu1.1

    Update to 1.5.8-1ubuntu1.1

  • unbound Ubuntu:18.04:LTS

    Versions
    • 1.6.5-1
    • 1.6.7-1
    • 1.6.7-1build1
    • 1.6.7-1ubuntu1
    • 1.6.7-1ubuntu2
    Affected ranges
    • ECOSYSTEM: < 1.6.7-1ubuntu2.1

    Update to 1.6.7-1ubuntu2.1

Original sources

Check your server →