p PatchFirst

CVE-2017-15107

CVE-2017-15107

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A vulnerability was found in the implementation of DNSSEC in Dnsmasq up to and including 2.78. Wildcard synthesized NSEC records could be improperly interpreted to prove the non-existence of hostnames that actually exist.

CVSS 7.5 · High · EPSS 2.6% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • dnsmasq

    Versions
    • up to and including 2.78: Affected

    No fix published

  • dnsmasq Debian:12

    Affected ranges
    • ECOSYSTEM: < 2.79-1

    Update to 2.79-1

  • dnsmasq Debian:13

    Affected ranges
    • ECOSYSTEM: < 2.79-1

    Update to 2.79-1

  • dnsmasq Debian:14

    Affected ranges
    • ECOSYSTEM: < 2.79-1

    Update to 2.79-1

  • dnsmasq Ubuntu:16.04:LTS

    Versions
    • 2.75-1
    • 2.75-1ubuntu0.16.04.1
    • 2.75-1ubuntu0.16.04.2
    • 2.75-1ubuntu0.16.04.3
    • 2.75-1ubuntu0.16.04.4
    • 2.75-1ubuntu0.16.04.5
    • 2.75-1ubuntu0.16.04.7
    • 2.75-1ubuntu0.16.04.8
    Affected ranges
    • ECOSYSTEM: < 2.75-1ubuntu0.16.04.10

    Update to 2.75-1ubuntu0.16.04.10

Original sources

Check your server →