CVE-2017-15277
CVE-2017-15277
This page contains facts from public vulnerability sources. Check the original advisory before updating.
ReadGIFImage in coders/gif.c in ImageMagick 7.0.6-1 and GraphicsMagick 1.3.26 leaves the palette uninitialized when processing a GIF file that has neither a global nor local palette. If the affected product is used as a library loaded into a process that operates on interesting data, this data sometimes can be leaked via the uninitialized palette.
CVSS 6.5 · Medium · EPSS 19.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
graphicsmagick Debian:12
- Affected ranges
- ECOSYSTEM: < 1.3.26-14
Update to 1.3.26-14
graphicsmagick Debian:13
- Affected ranges
- ECOSYSTEM: < 1.3.26-14
Update to 1.3.26-14
graphicsmagick Debian:14
- Affected ranges
- ECOSYSTEM: < 1.3.26-14
Update to 1.3.26-14
imagemagick Debian:12
- Affected ranges
- ECOSYSTEM: < 8:6.9.9.34+dfsg-3
Update to 8:6.9.9.34+dfsg-3
imagemagick Debian:13
- Affected ranges
- ECOSYSTEM: < 8:6.9.9.34+dfsg-3
Update to 8:6.9.9.34+dfsg-3
imagemagick Debian:14
- Affected ranges
- ECOSYSTEM: < 8:6.9.9.34+dfsg-3
Update to 8:6.9.9.34+dfsg-3
imagemagick Ubuntu:14.04:LTS
- Versions
- 8:6.7.7.10-5ubuntu3
- 8:6.7.7.10-5ubuntu4
- 8:6.7.7.10-6ubuntu1
- 8:6.7.7.10-6ubuntu2
- 8:6.7.7.10-6ubuntu3
- 8:6.7.7.10-6ubuntu3.1
- 8:6.7.7.10-6ubuntu3.2
- 8:6.7.7.10-6ubuntu3.3
- 8:6.7.7.10-6ubuntu3.4
- 8:6.7.7.10-6ubuntu3.5
- 8:6.7.7.10-6ubuntu3.6
- 8:6.7.7.10-6ubuntu3.7
- 8:6.7.7.10-6ubuntu3.8
- 8:6.7.7.10-6ubuntu3.9
- Affected ranges
- ECOSYSTEM: < 8:6.7.7.10-6ubuntu3.11
Update to 8:6.7.7.10-6ubuntu3.11
graphicsmagick Ubuntu:Pro:14.04:LTS
- Versions
- 1.3.16-1.1ubuntu2
- 1.3.16-1.1ubuntu3
- 1.3.18-1ubuntu3
- 1.3.18-1ubuntu3.1
- 1.3.18-1ubuntu3.1+esm1
- 1.3.18-1ubuntu3.1+esm2
- 1.3.18-1ubuntu3.1+esm3
- Affected ranges
- ECOSYSTEM: < 1.3.18-1ubuntu3.1+esm4
Update to 1.3.18-1ubuntu3.1+esm4
graphicsmagick Ubuntu:16.04:LTS
- Versions
- 1.3.21-3
- 1.3.23-1
- 1.3.23-1build1
- 1.3.23-1ubuntu0.1
- 1.3.23-1ubuntu0.2
- 1.3.23-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.3.23-1ubuntu0.4
Update to 1.3.23-1ubuntu0.4
imagemagick Ubuntu:16.04:LTS
- Versions
- 8:6.8.9.9-5ubuntu2
- 8:6.8.9.9-6
- 8:6.8.9.9-6build1
- 8:6.8.9.9-7
- 8:6.8.9.9-7ubuntu1
- 8:6.8.9.9-7ubuntu2
- 8:6.8.9.9-7ubuntu3
- 8:6.8.9.9-7ubuntu4
- 8:6.8.9.9-7ubuntu5
- 8:6.8.9.9-7ubuntu5.1
- 8:6.8.9.9-7ubuntu5.2
- 8:6.8.9.9-7ubuntu5.3
- 8:6.8.9.9-7ubuntu5.4
- 8:6.8.9.9-7ubuntu5.5
- 8:6.8.9.9-7ubuntu5.6
- 8:6.8.9.9-7ubuntu5.7
- 8:6.8.9.9-7ubuntu5.8
- 8:6.8.9.9-7ubuntu5.9
- Affected ranges
- ECOSYSTEM: < 8:6.8.9.9-7ubuntu5.11
Update to 8:6.8.9.9-7ubuntu5.11
imagemagick Ubuntu:18.04:LTS
- Versions
- 8:6.9.7.4+dfsg-16ubuntu2
- 8:6.9.7.4+dfsg-16ubuntu3
- 8:6.9.7.4+dfsg-16ubuntu4
- 8:6.9.7.4+dfsg-16ubuntu5
- 8:6.9.7.4+dfsg-16ubuntu6
- Affected ranges
- ECOSYSTEM: < 8:6.9.7.4+dfsg-16ubuntu6.2
Update to 8:6.9.7.4+dfsg-16ubuntu6.2
Original sources
- https://www.debian.org/security/2017/dsa-4040
- https://usn.ubuntu.com/3681-1/
- https://github.com/neex/gifoeb
- https://www.debian.org/security/2018/dsa-4321
- https://www.debian.org/security/2017/dsa-4032
- https://github.com/ImageMagick/ImageMagick/issues/592
- https://lists.debian.org/debian-lts-announce/2018/08/msg00002.html
- https://github.com/ImageMagick/ImageMagick/commit/9fd10cf630832b36a588c1545d8736539b2f1fb5
- https://usn.ubuntu.com/4232-1/
- https://nvd.nist.gov/vuln/detail/CVE-2017-15277