CVE-2017-15595
CVE-2017-15595
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An issue was discovered in Xen through 4.9.x allowing x86 PV guest OS users to cause a denial of service (unbounded recursion, stack consumption, and hypervisor crash) or possibly gain privileges via crafted page-table stacking.
CVSS 8.8 · High · EPSS 1.6% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
xen Debian:12
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Debian:13
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Debian:14
- Affected ranges
- ECOSYSTEM: < 4.8.2+xsa245-0+deb9u1
Update to 4.8.2+xsa245-0+deb9u1
xen Ubuntu:18.04:LTS
- Versions
- 4.9.0-0ubuntu3
- 4.9.0-0ubuntu4
- Affected ranges
- ECOSYSTEM: < 4.9.2-0ubuntu1
Update to 4.9.2-0ubuntu1
Original sources
- https://lists.debian.org/debian-lts-announce/2018/10/msg00021.html
- https://xenbits.xen.org/xsa/advisory-240.html
- https://lists.debian.org/debian-lts-announce/2017/11/msg00027.html
- https://www.debian.org/security/2017/dsa-4050
- https://www.exploit-db.com/exploits/43014/
- https://support.citrix.com/article/CTX228867
- https://security.gentoo.org/glsa/201801-14
- https://nvd.nist.gov/vuln/detail/CVE-2017-15595