CVE-2017-16114
CVE-2017-16114
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The marked module is vulnerable to a regular expression denial of service. Based on the information published in the public issue, 1k characters can block for around 6 seconds.
CVSS 7.5 · High · EPSS 1.7% · Fix available
- Published
- Updated
Affected products and versions
marked node module
- Versions
- All versions: Affected
No fix published
node-marked Debian:12
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
node-marked Debian:13
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
node-marked Debian:14
- Affected ranges
- ECOSYSTEM: < 0.3.9+dfsg-1
Update to 0.3.9+dfsg-1
marked npm
- Affected ranges
- SEMVER: < 0.3.9
Update to 0.3.9
node-marked Ubuntu:16.04:LTS
- Versions
- 0.3.2+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published